2MB free on AR150 after installing 3.201

This has been a major point of contention for a lot of people who are trying to use the 3.201 firmware on GL iNet products with 16MB of flash. You are not alone. See:

Related on missing free space and DNS leak of 3.201, it can be you should use the firmware 3.105. Thats the last know working fine firmware for me.

In case somebody stumbles on this thread it may help to know I was able to remove some packages from Applications > Plug-ins, which freed up a little space. I won’t be using VPN on this router, so:


Et voila:


1 Like

ps: Most of that reclaimed space was from gl-tertf (406.7KB). You can keep the vpn packages and it’ll still show 3MB free I believe.

If you ditch tertf, then you can also delete the mac-vendor.db for another meg.

1 Like

You have an USB slot. You can put an old USB flash memory there (a little and tiny model not big) and make extroot /overlay to add this USB memory extra space to the router. For example USB is 512Mb, you will have 480Mb extra space for adding plugins, etc…
This is very easy in firmware 3.201 in Luci > System > Mount Points > Add >Select USB Device> /make Overlay >reboot. I have did this with AR750, same space problem after update to 3.201 firmware.

1 Like

@eric thanks for mentioning me! i am still curious, why would even this update be offered if it causes so much trouble?! is not it possible to programmatically check the requirements and at least warn the user of the potential problems? @GLi guys are not Microsoft or Apple, hence it came as a surprise…

Let me be clear:

3.201 contains important bug fix, major openwrt upgrade to 19.07. Read the release notes before you upgrade.

OpenWrt 1907 needs more space for the kernel and this cut the available space.

If 2MB is not enough, you can use clean openwrt firmware, use exroot, or use old firmware. It is just easy. If you prefer to use a vanilla openwrt firmware well, why keep criticizing the default firmware.

1 Like

Thank you for clarifying the reasons and listing the options.

FWIW, I did see the low space warning before installing Luci which helped inform me about the issue.

Using the OpenWrt firmware was NOT my preferred solution, but it was forced on me as the default firmware does not function how I need it to in all my use cases. The other issue I have is about half my GL iNet routers are still not supported by a released version of OpenWrt firmware, so I am forced to use the GL iNet firmware if I wish to use the routers at all. Hopefully once OpenWrt 21.02 is released, I will have a choice of firmware for all my GL iNet routers.

I believe that all users of GL iNet routers hope for better firmware from GL iNet in the future, so we don’t have to look for other firmware solutions. We take the time to make these comments so maybe someone will take note of the issues and fix these issues in future versions of the firmware. Since you took away the bug list, the forum is the only place we can bring up issues with your firmware.

“Although your customers won’t love you if you give bad service, your competitors will.” Kate Zabriskie, Founder Business Training Works

Thank you for providing the tutorial. Actually it doesn’t work in my case.
The Stick is mounted but free space remains low (about 2MB).

Any idea what’s wrong in my case?

@elorimer: Do you know where it’s located? I did a search but it didn’t show up…

1 Like


Then uninstall gl-tertf.

The only reason for doing this is to create room if you need it to install something else, I think, and most of these packages are really small. I think all you need is one free byte at the end of the day. Any free memory is just going unused.

I’m wondering though, if I built an image without these things, would I I create twice the free space?

Edit: I poked some more at this with my Mango and built several images with Imagebuilder (new to me, but the instructions are very clear). I got rid of all the ipv6 stuff, also ppp, gl-tertf and a few other things. Never could get rid of nodogsplash. That image was 1 meg smaller, and I ended up with 3.7meg free. Then I added back in luci, nano, htop, adblock, sqm and the associated luci files, and ended up with an image about .5 meg larger than stock but with 2.7meg free.

This was all really fun and easy. I just have to remember if I run into issues to flash back to stock. But it does seem straightforwrd if you have size problems to delete some stuff and make room for other stuff.

Try several times, I don’t know why but I had to do several times and reboot each time.

I saw that some people had ticked option Enable but I don’t have it enabled and it’s ok. May be i had enabled before I rebooted and then it was not enabled again but when I saw the extra space was ok then I didn’t touch it anymore. Good luck.

I will keep trying.
With ticked option Enable the Router will not boot. Removing the stick and it’s working again.

Is your Stick in ext4 format ?

Yes, it’s in ext4 format.

I don’t know more.
I know that I had to make it few times to success that USB stick was recognized as /overlay and see that I have extra space for plugins packages. After that no problems at all with space in routers (2xAR750).

I’m connected to a B1300 and don’t see the “Luci > System > Mount Points” menu option. Is there a package I need to install or does it only show when you have usb / micro sd cards inserted? I don’t have one inserted right now. Interested in this technique.

Sorry, I can’t help you, I only have AR750S and AR750.
But that new fonction (Mount Points) appears in firmware 3.201 or 3.203 only, not previous firmwares and in Luci config page, of course