5GHz WiFi not available when Channel set to Auto

Opening the Wireless page, I have this pop-up:

5GHz Wi-Fi will be temporarily unavailable because a radar is using the channel which is currently router using. (sic)

But the current setting for Channel is: Auto

The hint for Channel says: When you select the “Auto” option, Wi-Fi will not automatically switch to the DFS channel.

So it seems the pop-up message and the settings are in conflict.

Sorry, forgot to say originally, this is a Slate AXT1800 running 4.1.0 beta3.

Are you repeating a 5Ghz signal?

What region is the router setup for? Germany allows certain channels that are blocked in the U.S. and vice versa.

Thank you for your feedback.
This is a known bug and we are working on fixing it. The router don’t select the DFS channel when the user selects “Auto”. But this version of the firmware incorrectly performs DFS detection on all channels.