Adding USB Wi-Fi to Brume2?

I have a TP Link T2 nano USB WiFi. This USB WiFi works on me Nanopi R5S.
When I plug it into the Brume 2, I install the driver’s but I don’t see the wireless settings. Dmsg didn’t show much. Can someone help me get wifi working?

What is the name of the driver package that you installed? It looks like that USB wifi adapter has the RTL8811AU chipset.

I do not work for and I am not directly associated with GL.iNet

I reset the whole device thinking I did something wrong. I will retry and see if that driver works.

What do you get when you run

iw list

FWIW, it seems to be a bit picky - I just tried with three wireless adapters and only one of them worked. One of the others returned info from iw list, but was never properly recognized. I may try to mess with it more later.

Was this on the Brume 2?


Adding additional characters for the 20 char limit :confused:

Also FWIW the one that didn’t really work was an adapter using a similar driver to what you’re looking at (a RTL8821AU, in my case.)

Can you link me the USB wifi? I want to buy the right one :slight_smile:

It’s an old 2.4 300mbps model.

I’ve got a couple of others on order. Let me see if they work first?

Sure thing. Thank you :+1:

I’m also want to use sometimes an wifi adapter to my Brume 2.
I hope will find a good solution.

Update for those interested.

I ordered this, but got this. Which, like, better chipset, so whatever, right? I also have another copy of the second one coming.

Packing was… a bit less than professional. So there’s that.

The bigger issue is that there seems to be some sort of issue with getting it to work on the Brume 2. It works fine on a stock OpenWrt build of the original Brume, but crashes when drivers are installed and you insert it on the Brume 2. I’m guessing that’s down to something in the custom Mediatek kernel that won’t be resolved until it goes more stock.

So… not great options. I could order a rtl adapter, but goodness those are bad. I may look into additional options, but so far things aren’t great.


How about find an old router and set it as AP then connect to LAN port of Brume 2? It should have a similar effect.

Of course I could connect one of my spare Ubiquiti APs using it’s PoE adapter - I could probably even run the Brume 2 off its USB port - but it seems rather bulky and not necessary?

I’m not looking for access point mode, I’m looking for client mode. :+1:.

@alzhao – was the wireless page removed from luci? I can’t seem to find it.

Because of there is no WiFi config, I think.

Anyway to add the wireless page back?

Maybe try install a supported WiFi dongle (like old 2.4G only dongles) and install the driver and the config will be there.