AdGuard Home & Brume

Hi,

I am using the OpenWRT based image for my Brume and recently upgraded to 3.104 and therefore decided to switch from the adblock OpenWRT package to AdGuard Home.

Since I was a bit curious as to what kind of devices query which domain I upped the query logging in AdGuard to seven days from the default 24h. This morning I now realised that the query log is stored in /etc/AdGuardHome/data and the logging caused the internal storage to run full.

  1. Is there a way to reconfigure the log location for AdGuard? (it seems to rotate files so symlinking it is probably not enough)
  2. would it be an idea to expose the AdGuard dns directly in a future upgrade? Currently all DNS queries come from localhost which makes the logging less useful

Today I noted again that even with the one day query log the internal memory was running out (it did not log any queries in the last five days because the disk was full). I also checked the Github repo of AdGuard and there does not seem to be a way to customise the location for the querylog, so I ended up disabling it.

Do you have any special configuration in AGH?
I haven’t seen feedback from other users about this BUG.

Hi @luochongjun,

thanks for checking back in. No, apart from enabling a few block lists I don’t think I have added any special configuration.

bind_host: 0.0.0.0
bind_port: 3000
users: []
http_proxy: ""
language: ""
rlimit_nofile: 0
debug_pprof: false
web_session_ttl: 720
dns:
  bind_host: 0.0.0.0
  port: 3053
  statistics_interval: 7
  querylog_enabled: false
  querylog_file_enabled: true
  querylog_interval: 1
  querylog_size_memory: 1000
  anonymize_client_ip: false
  protection_enabled: true
  blocking_mode: custom_ip
  blocking_ipv4: 165.22.57.39
  blocking_ipv6: '::'
  blocked_response_ttl: 10
  parental_block_host: family-block.dns.adguard.com
  safebrowsing_block_host: standard-block.dns.adguard.com
  ratelimit: 20
  ratelimit_whitelist: []
  refuse_any: true
  upstream_dns:
  - 9.9.9.9
  - 149.112.112.112
  bootstrap_dns:
  - 9.9.9.9
  - 149.112.112.112
  all_servers: false
  fastest_addr: false
  allowed_clients: []
  disallowed_clients: []
  blocked_hosts: []
  cache_size: 4194304
  cache_ttl_min: 0
  cache_ttl_max: 0
  bogus_nxdomain: []
  aaaa_disabled: false
  enable_dnssec: false
  edns_client_subnet: false
  filtering_enabled: true
  filters_update_interval: 24
  parental_enabled: false
  safesearch_enabled: false
  safebrowsing_enabled: true
  safebrowsing_cache_size: 1048576
  safesearch_cache_size: 1048576
  parental_cache_size: 1048576
  cache_time: 30
  rewrites: []
  blocked_services: []
tls:
  enabled: false
  server_name: ""
  force_https: false
  port_https: 443
  port_dns_over_tls: 853
  allow_unencrypted_doh: false
  strict_sni_check: false
  certificate_chain: ""
  private_key: ""
  certificate_path: ""
  private_key_path: ""
filters:
- enabled: true
  url: https://adguardteam.github.io/AdGuardSDNSFilter/Filters/filter.txt
  name: AdGuard Simplified Domain Names filter
  id: 1
- enabled: false
  url: https://easylist-downloads.adblockplus.org/easylistchina+easylist.txt
  name: EasyList China+EasyList
  id: 2
- enabled: true
  url: https://adaway.org/hosts.txt
  name: AdAway
  id: 3
- enabled: false
  url: https://hosts-file.net/ad_servers.txt
  name: hpHosts - Ad and Tracking servers only
  id: 4
- enabled: true
  url: https://www.malwaredomainlist.com/hostslist/hosts.txt
  name: MalwareDomainList.com Hosts List
  id: 5
- enabled: true
  url: https://raw.githubusercontent.com/Perflyst/PiHoleBlocklist/master/SmartTV-AGH.txt
  name: Perflyst and Dandelion Sprout's Smart-TV Blocklist
  id: 1599026958
- enabled: true
  url: https://raw.githubusercontent.com/mitchellkrogza/The-Big-List-of-Hacked-Malware-Web-Sites/master/hacked-domains.list
  name: The Big List of Hacked Malware Web Sites
  id: 1599026959
- enabled: true
  url: https://raw.githubusercontent.com/Spam404/lists/master/main-blacklist.txt
  name: Spam404
  id: 1599026960
- enabled: true
  url: https://raw.githubusercontent.com/durablenapkin/scamblocklist/master/adguard.txt
  name: Scam Blocklist by DurableNapkin
  id: 1599026961
- enabled: true
  url: https://raw.githubusercontent.com/hoshsadiq/adblock-nocoin-list/master/nocoin.txt
  name: NoCoin Filter List
  id: 1599026962
- enabled: true
  url: https://dbl.oisd.nl/
  name: oisd.nl
  id: 1599026963
whitelist_filters: []
user_rules: []
dhcp:
  enabled: false
  interface_name: ""
  gateway_ip: ""
  subnet_mask: ""
  range_start: ""
  range_end: ""
  lease_duration: 86400
  icmp_timeout_msec: 1000
clients: []
log_compress: false
log_localtime: false
log_max_backups: 0
log_max_size: 100
log_max_age: 3
log_file: ""
verbose: false
schema_version: 6

Hi @luochongjun
Not sure if it is similar issue.
My MV-1000 (on 3.104 with adguard) typically run out of memory after 3 days. Rebooted, and memory used after 17 hours, it has already reached 48%. Observation when the memory usage increases, will have frequent Wifi drops (an Alfa dongle).
Even if Adguard is not used, the memory usage still increases. Not sure of the reason/s.

However, my A750S (on 3.104 with adguard) is more stable, with memory hovers around 50% for a long time.

are you talking about memory as in ram, or memory as in storage?

A snapshot maybe more better as I’m not that tech-savvy.

I don’t (didn’t) check everyday but my Brume worked well for 11 days before I started rebooting it for an unrelated VPN problem. I have some very big blocklists and here’s the memory status after 20 hours.


Then we are talking about two different things. I am talking about disk space, while you are talking about ram.

I have the same issue, the Free memory drops to 7% after a day
in my case AdGuard uses like 700 MB on Brume 1000 (no wifi model)

USE Putty to connect
To see the memory in SSH terminal
after login, type:
top

You will see this: (no upload of pictures allowed for me yet)

Mem: 559968K used, 462960K free, 968K shrd, 422288K buff, 60580K cached
CPU: 22% usr 41% sys 0% nic 35% idle 0% io 0% irq 0% sirq
Load average: 1.54 1.75 1.80 2/92 2334
PID PPID USER STAT VSZ %VSZ %CPU COMMAND
2156 1 root S 4100 0% 3% /usr/bin/gltertf
28669 1 root S 701m 70% 1% /usr/bin/AdGuardHome --glinet -c /etc/AdGuardHome/config.yaml -w /etc/AdGuardHome

USE WinSCP to connect
in /etc/AdGuardHome/config.yalm --> I reduced the log size to 50 and age to 2.

log_compress: false
log_localtime: false
log_max_backups: 0
log_max_size: 50
log_max_age: 2
log_file: “”
verbose: false
schema_version: 6

in /etc/init.d/AdGuardHome --> I have commented out system logging for the moment…
changed this line
from:
procd_set_param command /usr/bin/AdGuardHome --glinet -c /etc/AdGuardHome/config.yaml -w /etc/AdGuardHome -l syslog
To:
procd_set_param command /usr/bin/AdGuardHome --glinet -c /etc/AdGuardHome/config.yaml -w /etc/AdGuardHome #-l syslog

USE Putty
type:
/etc/init.d/AdGuardHome Stop
/etc/init.d/AdGuardHome Reload

for the moment I have 44% Free memory

If the memory will drop again then I will use the Shedule Cron to run the commands to reload AdGuardHome at 23:59 each day…

hope it helps and I hope someone finds a better way for this issue…
Also a solution for the AdGuardHome Update pop up message…

1 Like

Free memory dropt to 31% and recovered a day later to 35%
I guess it is working for the moment.

MV1000 and S1300 updated the 3.105 beta firmware and fixed the AdGuardHome upgrade issue. Other models do not support AdGuardHome, but I can provide the test firmware.

2 Likes

Want adguard on ar750s latest release pls

@luochongjun Thanks, updating is working great now :slight_smile:

2 Likes