Adguard home Dns bug?

I use adguard home and wireguard client with policy based routing

my pc is connected to my isp and have the wireguard Vpn dns <— strange

And my other pc is connected to the wireguard Vpn have the dns from adguard home <— strange

My phone is connected to my isp have adguard home dns that’s correct

Is this a bug?

And is it possible to have a backup wireguard Vpn if the vpn server goes down the router should switch to another Vpn config file that would be nice.

What is the Model, Firmware version, and adguardhome version?

Is override DNS settings for all clients turned on?

Did you add Wireguard VPN DNS to your computers preferred DNS settings in adapters ?
What DNS is the Adguardhome using and is it configured correctly?

:gl_emoji_dizzy:I do not work for and I am not directly associated with GL.iNet :gl_emoji_shacking:

Have you tried setting the dhcp-option for assigning the AGH server for DNS in dnsmasq to your DHCP clients?

Inside of Luci, you can go to Network>Interfaces>LAN(edit)>DHPC Server Tab>Additional Settings and under dhcp-options at the bottom add 6,<IP address of AGH> to ensure your clients use AGH for DNS service.

Slate ax firmware 4.1.0

Adguard home 0.107.8

Override for all clients is off

I don’t think I added any dns adress on my pc but will double check later

Adguard home uses as dns

@Bitty_Bytes no didn’t tested thanks for the tip it’s not really a problem with the dns it was just strange why my windows pc shows Vpn dns and use my isp connection


Pc dns is fixed looks like a installed Vpn app changed dns settings

The other pc which uses Vpn still use adguard home dns is this correct?

So if you enable override for all clients it should always use the adguard DNS. This should work even if your DNS is hard coded on the computer like from the VPN app.