AdGuard stop working

Running 4.0.1 bêta 2 on the flint.
After about 30 days of usage, yesterday evening AdGuard stopped working.
To be more precise AdGuard was still up with no errors but no dns requests were forwarded to it.

The dns configuration of my device did not change (they were still pointing to the router) but the ads were not blocked anymore and I could not see any query in the AdGuard query logs.
It seems like the standard dns was taking over without forwarding.

What I tried:

  • stopping starting AdGuard ---- NOK
  • updating AdGuard — NOK
  • reboot of the whole router — OK. This solved the issue

Did anybody experience this behavior?


You can check the /etc/config/dhcp file and see if the dnsmasq section has the following lines, which are to forward DNS requests to AdGuard Home:

option noresolv '1'
list server ''

I do not work for and I do not have formal association with GL.iNet

Yes the lines are there, but now everything works fine and it was solved simply rebooting the router.