AdGuardHome Question

Hi using the GL-MV1000 how do you enable the AdGuardHome page it’s shows no statistics at all but the Dashboard works fine.

Have you enabled it ? There is a toggle on the right “Enable the AdGuardHome process”

Hi yes it’s enabled and I’m im using AdGuard’s DNS servers, the statistics page works fine.

A typical case is when the DNS request is encrypted before the router.
If we block or rewrite a DNS query with AdGuardHome (router), the request must be sent in plaintext until it is received by the router.

Previously, DNS requests were not encrypted, so the problem was that geographic information was leaked through the request. Individual identification is not impossible for those who have a lot of personalized data.
Therefore, it has become common in recent years to encrypt DNS requests using HTTPS or etc.

That said, half of the reasons companies encourage them are because they want to monopolize their personalized data.
Please note that it is currently implemented in almost all OS, WEB browsers, etc. and is enabled by default.

Example Android 10:

When disabled:

Wow sounds good but I’m a little to a lot lost on you’re reply, what do I need to check.

no need to worry!
The feature that encrypts all DNS requests is, in other words, a feature that reassures the user.
That is, it must be implemented so that anyone can find and disable this setting.
Except for exceptional environments such as double NAT, you only need to check the client settings in a few places.

It’s very simple if the client is an Android or iPhone.
As far as I know, on most devices, only the OS, VPN (or proxy), and the apps you actually use. Those can send or tamper with DNS query.
The only caveat is that the app you’re DNS request with may be the you’re viewing app or GoogleChrome (or other WebView).

If the client is Windows or Mac, you need to know what the background processes allowed by the firewall are doing.
But you probably already know it. Most processes are irrelevant.

And, about the location where there is a setting related to DNS encryption.
There are only ambiguous label with apps because companies want it to be activated. You can usually find it in network settings.
If not, it’s in security or privacy settings. At the very least, it will never be placed that only technicians can find.

Here are some examples:

Hi i tried the setting but it makes no difference but i did find a problem in AdGuard Settings Page Encryption settings it wont enable and comes up with a message about port 443

443 is used by the router.

What firmware version are you using in MV1000?

Hi thanks for the reply still struggling on this Capture

Can you try the 3.203 beta GL.iNet download center

Hi there doesn’t seem to be any mention of my problem in the release:
Based on openwrt 19.07.7 (MV1000,X1200,E750,XE300)
Based on QSDK11 (B1300,S1300,AP1300)

Important bugfix:

  1. Fixed a BUG where the OpenVPN connection status was displayed incorrectly on the E750 LCD
  2. Fixed XE300 modem manual settings always being overwritten

Do you know what uses the port 443, thanks

Lighttpd. Check /etc/lighttpd/conf.d/ and remove 30-openssl.conf if you do not use https

Thanks fir the last post, I did download the beta and the current version flashed the beta, still the same and then reloaded the current version, by the way I did reset all settings to factory default settings, both times.
I think it’s something to do with the port 443 because the page I previously showed will not enable, also if you toggle AdGuard home off and on again it never loads until you refresh the browser then come back to AdHome page and it’s enabled again.
One last comment AdGuard is actually working, before I purchased this router I used PiHole, Sham that’s not on the list of plug-ins.

I realized that AGH was too resource hungry (even for a MV1000) and replaced it with adBlock. And now I can have DNS stats for my LAN clients (and not that useless

Hi I noticed that on the list when I updated it, it might be worth ago later.

I installed adBlock but it don’t show up in the menu and I uninstalled AdGuard and most of it is till in the system including the static home page, any ideas did try a restart.

Now AdGuard is missing from the public list, I may need to refashion the current firmware if I can’t find Adblock

I tried several times but you cant uninstall AdGuard it remains in the menu Plus it disappears from the plug-in list, and adBlock does not install.
I have tried this from factory settings and factory firmware.

You cannot uninstall it. Just turn it off is okay.

I did not mention removing AGH, I just disabled it. Adblock menu appears in LuCI (only if you install the LuCI part), not in the gl.inet GUI.