Announce service does note autostart

I am tring to setup an mdns service to announce the web server running on the router on port 80.
if i run the announce service from the shell it works correctly, but it does not autostart when i turn on the router:

# not resolving http://gl-ar300m.local/
$ /etc/init.d/announce restart
# now works

Have you Enabled the init.d script to start up automatically in the right sequence on boot? There has to be a link to that script in the /etc/rc.d directory, with name S##announce where ## is the sequence number for execution after other dependencies have started.

There is a LuCI->System->Startup webpage to set up script startups (I am going by memory and am not 100% sure if that is the location of the webpage).

I do not work for and I do not have formal association with GL.iNet

Pls enable it for autostart

/etc/init.d/announce enable 

If does not start after reboot, pls give log.