AR-750 won't reconnect

You can find it in here.

Thanks, I will check that out.

Yesterday, I confirmed the Jetpack is transmitting on 5Ghz and the 750 transmitting on 2.4Ghz. This morning I encountered another instance of the 750 dropping connection and not re-connecting, so it doesn’t appear to be caused by using the same channel for both WAN and LAN sides.

Are you using the latest v3.x testing firmware? If so, it might be a bug. Because it has a blocklist machine, it will add the SSID to block list when it fails to connect it. Will fix it later.

Having the same problem with the Glinet SLATE (and firmware I’ve spent all day using LUCI to configure a client-mode bridged connection to an AP, only to discover this bug myself. Anytime the Access Point to which I connect loses power/connection, the GLINET does NOT reconnect on its own (a reboot fixes it, as does reconnecting via the admin page). This makes it almost unusable for my particular uses.

Hi @John use the travelmate service, it will reconnect automatically if it looses connection to the main router

Sat Mar 9 00:32:28 2019 travelmate-[1.2.0]: interface ‘trm_wwan’ on ‘radio1’ connected to uplink ‘VIKRANT84/-’ (GL-AR750S, OpenWrt 18.06.1 r7258-5eb055306f)
Sat Mar 9 03:20:29 2019 travelmate-[1.2.0]: uplink ‘VIKRANT84/40:9B:CD:2F:B4:50’ is out of range (0/35), uplink disconnected (GL-AR750S, OpenWrt 18.06.1 r7258-5eb055306f)
Sat Mar 9 03:20:49 2019 travelmate-[1.2.0]: interface ‘trm_wwan’ on ‘radio1’ connected to uplink ‘VIKRANT84/-’ (GL-AR750S, OpenWrt 18.06.1 r7258-5eb055306f)

You can see here that it lost connection at 03:20:29 and then it reconnected in 20 seconds

Travelmate - more details here:

what is “travelmate?”

Got travelmate going, it seems to be working. Thank you for the help!

1 Like

Yes, of course I saw the preceding messages. Both refer to travel mate. Neither explained what it is.

No problem. I’ll just return this buggy piece of junk to Amazon. Thanks for your time.

1 Like

Hello Thunk, sorry we didn’t give more details, follow this link to a different thread AR750s Keeps disconnecting - #32 by wellnw

Travelmate is a package made for open Wrt firmware, it has a set of instructions and config to help you use a router as a travel router, it will easily connect to a wifi and repeat it, it is stable and it has a special script to connect easily to captive portals on hotels wifis. Well basically travelmate should be something implemented into our small router the Slate. In fact it is, they call the script, gh health, but looks like this one isn’t working well for some of us, so we are using the wonderful capabilities of this router to load different scripts. You are not entitled to use only official releases, if you have enough knowledge, you can even write your own software and make it work exactly as you would like to.

What you need to do is simple :slight_smile:
First step is, delete this package using Puty (you will need to use some google)

killall gl_health
mv /usr/bin/gl_health /usr/bin/gl_health_bak

Then install travelmate files from Luci, to be more precise, packages.

After that, follow the instructions I sent you on the link.

There you go you have installed and set travelmate to enabled, now hopefully, you will have almost no disconnections and the router will reconnect automatically and quickly.

This router is a wonderful piece of tech, if the software was good. bugs are distroying it. hopefully, the devs are watching our frustration and they will soon release a bugfree firmware.

I am having the same troubles using the Slate to repeat an iPhone hotspot connection to a LAN port. After a disconnection, the Slate won’t reconnect to the iPhone hotspot unless you manually force this in the Slate interface UI.

I have absolutely no idea how to install packages on the Slate. Can someone please send explicit
instructions or point to some online resources.


@dbbarron Hi
They dev team fixed the issu on the new firmware, so there is no need to install a package.
Just head to official support page for the slate and download the update file and upload it to the router. Please report back if you are still facing problems

Good luck

Which version has the fix? Is it the dev version or the production (V1) version or otherwise?

Do you have AR-750 or AR-750S?

Well, I suggest you install some new testing firmwares from here
For the slate

For the ar750

V1 is the original firmware

Works great!
Reconnects like a champ.

Hello I have the same issues but my Router says it is a “750m” which firmware can i use to solve my problem

If AR750 (while without external antenna) you should use this one

If AR750S (black with two antenna) you should use this one:

Got it works great now thank you!

This is getting closer, but still not solved. The new firmware does succesfully reconnect to the wifi source now, thanks!!

But… it won’t reconnect to the VPN unless I log into the web UI and manually connect.

So, the latest test Firmware is better, but the problem still isn’t solved.