AR-750S: No VPN reconnect attempts?


I’m running V3.22 on my 750S and I’m very happy with it. But sometimes I’m running into an issue:

Having the Wireguard Client enabled, it sometimes fails to connect after powerup when using the WISP mode. I guess the VPN might start the connection attempt before WAN is ready and connected to the internet.

The result is the message in the VPN client that it failed to connect. Not a problem so far, but it seems to not retry to reconnect automatically in this state. I’ve waited 5 minutes with that yellow state until I pressed “Cancel” and then “Connect” - where it immediately connected successfully.

Can you please check if the automatic retries are failing at some point, leaving the VPN client stuck in the failed state?

I also have noticed that the same happens when the Wireguard client connection times out (i.e. there is a break of internet connectivity). Wireguard status goes to yellow then and it will never reconnect, so any connectivity is lost until I end the existing (yellow) VPN connection and enable it again.

Seeing this also with 3.24 which I run since yesterday.

Which WireGuard provider did you pick? or the WireGuard server was set up by yourself?

I’m only connecting to my own Wireguard Servers (official Wireguard repo, Ubuntu Linux). Having my iPhone connected to the same server the connection is stable all over the day.

Just mentioned this in another thread and wonder if it’s related: I’ve been having the (oft reported) problem where the 750 wouldn’t reconnect to a wifi source that dropped and came back.

I tried the new test FW and it does indeed properly reconnect when the wifi source is restored; however, it does not restore the openVPN client connection unless/until I manually force a reconnect through the web ui (it shows that the vpn connect failed, I have to click abort, then I can reconnect the vpn)

Sounds well known to me! :wink:

@kyson-lok Suggestions?

Could you please ssh to the router, and execute this command? Please show me the result.