AR-750S Uboot recovery not working

Trying to upload a custom firmware build to an AR-750s and for some reason just cannot convince U-boot to talk to me! Hooked up the UART (maybe in the future those pins could come populated instead of just open guys… since the heatsink practically blocks the bottom of them and makes soldering especially fun), and I can see that UBoot properly goes into HTTP recovery mode if I hold the reset button for 5+ LED flashes.

An yet, no connectivity. I have tried two different laptops, each of the three ports on the AR-750s, and even to be safe hooked up a small 8 port switch in between. In all cases I cannot reach with my laptop configured on On the U-boot console all I get is “Trying eth0”, then about 20 -30 seconds later “ARP Retry count exceeded, trying again”

Any thoughts on what I’m missing? I’ve done this with many MiFis in the past and had no issues, but the 750s is just being a pain…

I’m having the same problem with my AR-750S. I’ve power cycled the device and brought it up to the U-Boot console with my ethernet cable plugged into all three ports. I get the same problem as you. I can’t even get ping $serverip to work. I’d like to use tftp and bootm to test kernels rather than HTTP recovery, but it’s probably the same yak that needing a shave.

For what it’s worth, the thermal pads holding the rear heat spreader/load plate onto the PCB aren’t so strongly adhesive they are difficult to remove. I took the screws out of the assembly and gently pried the lower (flat) heat sink off the PCB with fingertip pressure. The upper heat sink on the component side of the PCB will stay in place and makes an excellent anchor to masking-tape the pin header into place while soldering it.

Glad to hear it’s not just me! Hopefully somebody from GL sees this though they’re probably all getting geared up for CES right now…

Yea with a very pointy soldering tip and some steady hands I managed to solder mine without removing the heat pad from the back, but if I hadn’t been able to get in there that was my next plan. Good to know that you can take it off without having the one on the top come free… I’ve replaced CPU heatsinks on laptops before that have a similar kind of setup and the second you loosen the bottom part it all falls down needing new thermal grease/etc so was trying to avoid that ;o)

Which PC operating system are you using for? Windows or Linux? The old uboot has a bug on Linux.

I’ve has a similar set of symptoms with my AR-750S, delivered just before the holidays, not handling macOS, FreeBSD, or Linux for connectivity after seeming to enter uboot recovery. I haven’t had the time to trace down just what is happening, but it seems related to ARP.

It’s bad enough to have me documenting it sufficiently so that I can return it as defective. I bought the device to do development on and if its boot loader can’t be used to flash images, it’s not viable for that purpose.

Same exact machines, OSes, and interfaces with same exact configuration have no problems with OpenWrt failsafe mode for Archer C7v2 on OpenWrt master, either ar71xx or ath79 architecture, or with the AR-300M-Lite in uboot recovery.

Edit: Re-confirmed that I can reach an AR-300M-Lite in uboot without any issue.

There is a bug with Linux ARP and it should work with Windows without problem.

Can you try?

No Windows here, only FreeBSD, macOS, and Linux-based OSes. Is there another way to get this router functional?

1 Like

I fortunately don’t need uboot access at the moment on my 750S - but If I did I’d be in the same position as I only have access to Linux machines.
Have used uboot successfully on my MT300N V2 so I’m concerned should I need to on my new AR- 750S.

This really need a fix without having to modify the pcb to support a serial connection !

1 Like

Well hate to be the bearer of bad news but I tried with an Ubuntu laptop and when it didn’t work switched to another machine just to make sure it wasn’t a hardware compatibility issue. The second machine was running Windows 7 and had the exact same problem, no connectivity to uboot despite the uboot serial console saying it was good to go.

Sounds more like there is an issue with uboot and the 750s hardware. Is it possible that it’s not pulling the mac address properly or using the proper interface for the hardware? I have console access if there’s anything that you guys need to troubleshoot/assist on this…

1 Like

Any update on this ? Would have expected someone from gl-inet to have commented on this by now !

It doesn’t work on windows as well? Did you only attach one cable to the router? If you attach two or more cable on router, it won’t work.

If you had confirmed all you done is correct, please record a video step by step follow this guide Advanced Uboot - GL.iNet Docs.

OK just to confirm that after trying again, it DOES work on Windows. Oddly enough you have to open the webpage in a browser first before the device will respond to PINGs/etc, that’s why I missed it the first time around (after all the trouble under linux I had just been trying to get any sort of connectivity to the recovery address, didn’t think to try the browser BEFORE the command line…)

Did this UBoot issue get fixed in some later revision? or are all ar750s doomed to no linux support for UBoot? Also any hints/clues as to what the underlying problem actually is? (i.e. links to code?)

1 Like

This is fixed and in recent production it works without problems.

The code is in github and I am not sure if there is updated commit. Pls check.

Without access to a Windows machine, how can I update?

This is only for uboot update.

You can still update in the current firmware. If your brick your device pls find a windows machine if your uboot version is old.

How can I tell if the firmware in my uboot version will work with Linux?
I only have Linux and MacOS machines.

I don’t know.
If it does not work you have to find a windows machine.
the uboot itself should be able to be replaced but only do this if you have UART adapter.

Is there any danger of bricking the router if I try uboot with with a Linux machine?
Are there instructions to show how to connect and use a UART adapter? Can that be done using Linux and/or MacOS?

No danger to try uboot in any machine.

How can we obtain the working uboot image? doesn’t appear to have any commits of significance since August or early September 2018. A device delivered by Amazon (US) just before the Holidays has the defective uboot binary.

uboot-gl-ar750-ar750s-x750$ git log bin/uboot-gl-ar750s.bin
commit 6ba7e29bcc5c1c23c65b6ebf1fd2e30466f08fbb
Author: dengxinfa <>
Date:   Fri Aug 31 12:26:05 2018 +0800

    add bin folder