AR-750S Uboot recovery not working

How to you get to the serial pins? Are there screws under the bumpers on the bottom?

The two bumpers closest to the back (where the ports are) peel up to reveal two Philips head screws. Take the screws out then the real fun begins. You need a thin plastic pry tool ideally, or a small flat head screw driver un-ideally lol
There are 7 plastic clips on the top over that hold it snugly to the main case (Three at the back , two on each side). Gently work your way around, bringing the sides away from the top and you’ll hear each click apart. Once you have them all unsnapped the top and front (its all one piece) should open up like a book to expose the PCB inside.
After that, you will need to disconnect the two antenna connectors and in order to access the bottom of the circuit board, gently squeeze the inside part of each of the round antenna pivots. Each antenna assembly should then be able to be pulled out of the case and set aside so that there is space for the main circuit board to be lifted out.
Once you have the circuit board out, you need to do as mkxm described back in the second post of this thread. Remove the lower heat sink and solder pins into the pcb holes (unless you’ve got some pogo pins or the like handy!).

Compared to every other GLI product it’s definitely not the most hacker-friendly, but still by miles much easier than any consumer level product I’ve ever dealt with.

I have been able to confirm on my ar750s:

  1. Normal ethernet connection (as router) works as expected using Linux, MacOs, and Windows.
  2. Uboot Web UI does not work using Linux or MacOS.
  3. Uboot Web UI works using Windows 10. I had to travel and use a borrowed laptop to test this.
  4. Having read the description by jolouis in this thread of what is required to open the ar750s, and solder the required pins, I fear that I might damage the ar750s and void the warranty if I attempt this process.

Is there any way to replace the firmware containing the Uboot code without having to open the device and solder on the board? I can use Linux, MacOS, or with limited access, Win 10, to do a Uboot update. But, I need to be able to access the Uboot Web UI using linux (or MacOs) in the future.

I purchased this router based on its features, especially the Uboot ability to reload firmware if things go wrong. The ar750s is a great router, and I want to keep it and use it. If I can not upgrade it, can I return it for replacement of the Uboot firmware with the new version that does work using Linux?

1 Like

Seems you can use the router normally. Why you have to use uboot to flash the router while on travel?

You can upgrade uboot via uboot web page. You have to find a Windows machine to do this.

Upgrade uboot is the same step with upgrade firmware. Please download the latest uboot from

  • Connect your PC to the router’s LAN port, other ports are idle
  • Hold on the reset button and power up the device until the middle LED is lighted
  • Open Chrome browser, enter to access upgrade uboot page
  • Upload the uboot binary file and upgrade it, wait for the device boot up

You can check the uboot version after the device boot up.

root@GL-AR750S:~# strings /dev/mtd0 | grep -nr "U-Boot" | head -n 1
348:U-Boot 1.1.4-gcf378d80-dirty (Aug 16 2018 - 07:51:15)
1 Like

Travel is only one of the uses for the router. When at home (most of time) I use the router as extender, backup to main router, and to experiment with. I also support several facilities and individuals in my area that use wifi routers. I have been using dd-wrt software on most of the routers that I support. I would like to switch to using routers based on OpenWRT instead of dd-wrt. The ar750s appears to be a great router to experiment with for most of the applications I have. Your dual interface makes your routers especially versatile.

I understand that this is a new router design and that some features are still in development. So far I have been able to use updates or work around solutions to solve problems. I need the Uboot feature to work as specified and am trying to achieve that goal.

Would it be possible to create and load a special firmware that would update/patch the Uboot code without having to revert to using the UART?

You questions are just answered above.

Can this be uploaded to the router and written directly to /dev/mtd0 for those of us without Windows machines?

Presently running U-Boot 1.1.4-ga35cd45d-dirty (Jun 22 2018 - 12:48:24) which does not permit connection from non-Windows machines.

Edit: Successfully updated to the -201810080- U-Boot linked above and now able to connect using macOS. Thank you all!

Is this file for nand or nor upload?

It appears to be nor based on file name extension (.bin) but using nor upload on Win 10 machine failed. Still have 414:U-Boot 1.1.4-ga35cd45d-dirty (Jun 22 2018 - 12:48:24) version of Uboot.

The linked file is for UBoot itself, not either of the flash images. To upload it you have to use the UBoot update page. Re-read kyson-lok’s post carefully. Note it says “” as the page to do the update on.

If you go from there you should be able to upload the new Uboot and be all set.

Thank you for pointing out the correct url!
I used a windows 10 machine and flashed the Uboot update as @kyson-lok instructed.
Checked the Uboot version after boot and confirmed the install success.
I have also now verified that I can access the Uboot Web UI on both Linux and MacOs.
Thank you all for your help and great support.

1 Like

Can you run this command without having hardware serial access ?

Yes, I ran it from a ssh session as root.

Oh I didn’t think of ssh’ing into the device !

Thanks for replying.

Just borrowed a Windows Machine to update UBOOT.
Appears to have been successful as updated UBOOT reported via SSH.

OpenWrt 18.06.1, r7258-5eb055306f

root@GL-AR750S:~# strings /dev/mtd0 | grep -nr “U-Boot” | head -n 1
348:U-Boot 1.1.4-gcf378d80-dirty (Aug 16 2018 - 07:51:15)

I haven’t tried updating firmware via UBOOT but it’s nice to know it is available via Linux just in case.
Thanks to everyone for their support and help.


It is feasible, but you have to rebuild the firmware by yourself. Because of the official firmware has locked u-boot partition, you should remove the read-only flag, and rebuild it again.

1 Like

The fixed to access Uboot is to make sure it isn’t trying to access https version of uboot like if you edit it should pointed to
New browsers now trying the https version of websites

Coming back to this a couple of years later, this is more sinister… :slight_smile:

Firstly the uboot link to github changed : uboot-for-qca95xx/uboot-gl-ar750s-20201222-md5-901bf6ffffc79ff06aec709b669fdc18.bin at master · gl-inet/uboot-for-qca95xx · GitHub

Secondly I had no luck on windows 10 or windows 11 getting the recovery http page working. I thought I was going to have to upgrade manually in uboot via serial and tftp, but I found a work around.

Windows doesn’t seem to allow even the administrator to add entries to the arp table (arp -s [ip] [mac]) it gives an Access Denied error, but it does work with netsh

→ netsh interface ip add neighbors “” “” “00-03-8F-xx-xx-xx”

Replace with the mac address of your AR750S, and in my case the ethernet adapter was “Ethernet”.

This seemed to do the trick, and I was able to upgrade uboot via ( After upgrading uboot I now have access to the recovery webserver via linux.

Out of box Version : U-Boot 1.1.4-ga35cd45d-dirty (Jun 22 2018 - 12:48:24)
New Version : U-Boot 1.1.4 (Fri May 17 09:44:06 2019)

I hope this helps save someone some time :slight_smile: I don’t know how they can claim this is an arp bug in linux :upside_down_face: :roll_eyes: If anything manually adding an entry to the arp table in linux would probably work as well - the claimed “correct” behaviour in Windows is likely a behaviour that was recently fixed in Windows too… since linux/macos/windows all don’t work without the manual arp entry.


Odd… the original issue was with Windows working but all other OSes failing. Since GL updated their builds and image back in 2019 I have had 0 cases of new AR750s being unable to access uBoot HTTP recovery using Linux.

As suggested perhaps windows has now changed something internally. I don’t have an AR-750s on hand to try with Windows 10 at the moment but should be getting some more in this week. When I get them in I’ll see if I can re-produce your case and results.

1 Like

Sounds good, another angle I didn’t think of was that my uboot version was even earlier than the one causing people grief. By memory I purchased it as soon as the device was announced, reported version is in my post above.