AR300M connections/config

Hi Everyone,

I’m sorry for not understanding the instructions but talk of WAN/LAN & Repeater/Router seems to be rather flexible & as a result I do not think I am connecting my ARM300M properly.

What I want to do is connect a satellite receiver to the outside world through broadband/internet & achieve a connection to another country to access geo-localised programmes. using a VPN in the target country of course!

So I connect the sat receiver using ethernet to the LAN port of the ARM300M…It has NO wifi…The ARM300M is connected to my house wifi mesh to my ISP router…No WAN connection used at all…The ARM300M connects using openvpn to the VPN service I use BUT it seems the sat receiver is actually connecting to the internet directly & by-passing the VPN…Is that possible??? The IP address the sat receiver ‘gets’ is the local address in my home country NOT the target country!!

BUT if I connect to the ARM300M using it’s wifi network from another client (phone, tablet etc.) then it seems I am going thru the VPN as I want!!

SO, if what I am doing it is wrong then please tell me!! Or offer ideas that may help!!

Many thanks, Dave

Because you are using the eth-port for the SAT and wifi for the upstream, the AR300M is ‘just a switch’.
I don’t think you are able to just isolate one device in this setup.

A better way would be

  1. connect SAT to eth
  2. connect AR300M via ‘Internet → Wireless’

Then the traffic from all your devices, connect to the AR300M are routed in the VPN and don’t see the other devices within the LAN…
The easiest was should be to use two AR300M. Or do a lot of research in VLAN, Routing and other sophisticated techniques.

How are you able to have the GL-AR300M connect to the VPN provider without a WAN connection? If you have this working successfully, then you can try setting the Default Gateway on the satellite receiver to the IP address of the GL-AR300M, so traffic goes through it (you can also set a static IP address on the satellite receiver).

Normally, VPN only works with the GL-AR300M in Router network mode. The satellite receiver would be connected to the LAN port via Ethernet cable and the WAN would be wireless Repeater to the home mesh, or Ethernet to a nearby mesh node with a LAN port if available. The router’s WAN side would be on the same subnet as the home mesh and the LAN side has to be on a different subnet for routing to work. There should not be any problem with “double-NAT” with both GL-AR300M and ISP routers, which works fine for my home network.

I do not work for and I am not directly associated with GL.iNet

It seems that the connection are OK.

Can you check if you connect a PC to the LAN port, do you get IP from the VPN server? If yes then the satelite receiver should be fine.

If not you could do a further debug with the pc.

Hi Everyone,

Many thanks for the info & suggestions.

I have discovered where my problems were. I had downloaded the wrong openvpn config files from my VPN service.

The device is connected via LAN cable to ARM300M thence thru my wifi mesh to my ISP router & then to outside world to my VPN service…It connects fine & is giving a solid protected 24 hour service.

Cheers, Dave