AR300M Lite + psiphon VPN

I use qpython + psiphon VPN for android to access internet, but the psiphon restrict my phone from sharing the connection either from tethering or hotspot, so i use another app to share (netbridge) it allowed me to set a hotspot, it works fine and i can connect my win10 pc through proxy 192.168.49.1 port 9099, i try to use my GL-AR300M Lite as repeater so other device can connect… it connecting to the router but no internet, how do i set the proxy and port on the router?

I want to do the same thing but with https://www.your-freedom.net/ DNS connection.

Seems you need to set up a proxy on the router.

Is 192.168.49.1:9099 a sock proxy or http proxy?

It’s HTTP proxy, how do i set it up?

Maybe you need to consider https://openwrt.org/docs/guide-user/services/proxy/tinyproxy

Thank you, i might try it later, i need to figure it out & learn it first, temporary solution that i use for now is connecting internet on my android with qpython script + psiphon vpn --> share it with netbridge --> use huawei MiFi e5573 as repeater mode (no other setting just a password to a network) --> use AR300M on repeater mode --> all client is connected just fine with proxy setup (192.168.49.1;9099). The only question on my mind is “how is it huawei MiFi repeater can do it with no problem but gl.inet router can’t??”.

Why gl.inet didn’t have option to configure proxy + port under “password” when connecting to available network? (on repeater mode).

Sorry I have no idea of what you mean huawei mifi can do it. You mean Huawei mifi has UI to configure proxy?

Any screenshot? I never got an impression that this is done in mifi devices.

here is the screen shot from the huawei e5573 admin panel, i just need to connect using password only and that’s it… an extended wifi network, it never fail to repeat other network (forwarding) as long as i could remember.

any device can connect to it (Android, PC) but in order to have internet access every client must use http proxy 192.168.49.1 port 9099 (provided by netbridge app)


now the AR300M can connect to network from the huawei MiFi and pass it to other device, but same as the above, you need to configure proxy & port to have internet.

when i try to use AR300M as extender directly to the phone VPN network… it will connect as the green “sucess” show up but nothing on the dashboard.

but in luci it show that AR300M is connected to the vpn network from the phone, but the host IP is missing (?)

maybe in the future gl.inet can update the firmware so it can:

  1. forwarding any network (as repeater) VPN or not with just entering the necessary password just like the huawei MiFi or…
  2. adding (advance) option to enter Proxy and Port when necessary to connect & forwarding a network, (just like in android phone or in pc).

Let’s simplify this problem.

This set up has nothing to do with proxy as you set up proxy on your pc.

So it is only set up repeater to your phone’s hotspot.

Can you confirm that you changed AR300M’s IP to 192.168.88.1 and it works if you connect to Huawei’s ssid?

Connecting AR300M ot Direct-of-Xumi4A should just work easily. Seems the router didn’t get IP address so it does not show connection. Any special characters in your wifi password? Pls also check what is your firmware version of AR300M, 3.104?

  • The MiFi IP is always 192.168.8.1 (X ssid) and it never fail to forwarding/repeat any network so far.
  • I never use special characters on passwords of my wifi networks, the password from ssid Direct-of-xumi4A is B6P4ATcA provided by the netbridge app and cannot change.
  • AR300M (Y ssid) never fail to connect to MiFi (X) event it have the same IP 192.168.8.1 both (Y) and (X) …but then subnet conflict.
  • The AR300M IP is 192.168.8.2 (Y) but recently i can’t access admin panel of (X) while im connected to (Y) so i change the IP to 192.168.88.1 (Y), now i just need to connect to (Y) and i can control both router from (Y) connection.
  • the firmware version for AR300M is 3.104
  • try several times on AR300M connecting to (ssid) Direct-of-xumi4A with password B6P4ATcA, it connected with green success notification but nothing… the router didn’t get IP address.
  1. Direct-of-Xumi4A ----> AR300M = status is success connected but did not show.
  2. Direct-of-Xumi4A ----> MiFi (X) = connected easy and all client have internet (but signal to far form my room)
  3. Direct-of-Xumi4A ----> MiFi (X) -----> AR300M (Y) = connected and all client have internet.

Pls reset the router and start again. Then try again connect to Direct-of-xumi4A and wait for 1 minutes, then get the log. We can check what happened.

To get the log you can ssh to the router and use the following command:
logread
dmesg
ifconfig
ifconfig -a
cat /etc/config/wireless (pls remove your wifi key before send the log)

Hi. I think we are in the same country and I know what you want to achieve. Well, I guess you already know a lot about this, but in my opinion you are using too much resources to achieve it (I guess including your phone for psiphon). It is up to you, but if I may suggest you could use another method such as wireguard in the router. For me, I only need 4G modem and this AR300M for all devices to have internet at good speed, without need of proxy setup, and very much stable.

I reset the router (push button for 10 second) reconfigure it again, but still the same, but then i unplug the router for few days (out of town) then i’m back and turn the modem on… suddenly the router can read and display “Direct-of-xumi4A”, the IP address show up 192.168.49.41, i turn it off then turn it on again, the router auto connected again in repeater mode, everything seems normal.

Area code +62 ?? i’m newbie to networking stuff, the pandemic makes me cut corner, can you PM me how to set configuration of that ?