AR300M Locks up when connecting to Hotel

This is a first one for me after many many captive portal successes. I connected the router to the hotel’s wifi using the ssid and password provided. It connected but no internet. It tried to redirect my phone to a login screen that was managed by an apple product (it had apple in the portal name), but wouldn’t connect. I then connected directly to the wifi with my phone to the hotel wifi and went through the portal login without an issue.

I then went back to the 300m but it wouldn’t let the phone pass. I then cloned my phones mac to the router and it kicked me off the router. I rebooted the router but the wifi wouldn’t come back on (no ssid on any of my devices). Both the green and red lights were solid. I rebooted a few times but nothing.

I then held the reset down for 3 seconds and it came back. I reset the mac to the devices default, rebooted, and connected it to the hotel’s wifi again. Immediately the wifi disappeared and would only come back after reseting the network. I can reproduce the lockup just by connecting it to the hotel’s wifi.

I would love to troubleshoot this while I’m here. Does anyone have any ideas?

Do you have a cable?

If you can ssh to the router and get the content of


and get the log with


I don’t have cable I can only connect to it via WiFi. I’ve tried it at a few other WiFi spots that don’t have any captive portal and as soon as I click the button to join the WiFi, the router locks up. I just tried a factory reset and it does the same thing.