AR300M New Testing Version 3.100 released

Did anyone else notice that version 3.100 was released today?

https://dl.gl-inet.com/firmware/ar300m/nand/testing/

Seems OK - except that I have a problem where, when connecting to WireGuard® it is actually connected but the visuals in the menus show that it is still not connected (yellow indicator on WireGuard® client page, and “x” through “VPN” on the main Network page).

Hi, Thank you for your feedback.The reason is that the WireGuard application layer package is updated but the dependent kernel package is not updated. We are fixing it.

1 Like

Hi, fix done! You can try it again.
https://dl.gl-inet.com/firmware/ar300m/nand/testing/openwrt-ar300m-3.100-1218.tar
And the WireGuared updated to 0.0.20191012-1.

1 Like

For us, the ar300m wireguard client is in fact successfully connected to the wireguard server but displays as ‘abort’.

The new update released a couple hours ago (18 December) seems to work much better!

Definitely. Much much better.

1 Like

@lancer,
When do you expect a new Default Release for the GL-iNet AR300M?

With the launch of the APP, new official firmware will be available soon.

still not working for me. no connection possible to Mullvad Wireguard servers.

also adding a new Mullvad client profile is not working anymore …

Not sure if it’s better to create a new topic or reply here…
The same firmware release for GL-AR150M is not working properly.
After update I can’t load the default web page http://192.168.8.1. It prompts me to choose language, set admin password, and then the wheel spins infinitely. I can go to Advanced settings
http://192.168.8.1/cgi-bin/luci though.
Is that a firmware bug?
P.S. Of course, I tried keeping settings, wiping settings, tried clean install of 3.026 and then 3.100 on top - all with the same result

I have the same issue as above on Ar150. Have gone back to stable version.

I wrote to support, now that I know it’s not only me.
It’s a matter of time until they fix it

Any update? I‘m still facing the described issue.

Still no update? I still can‘t setup Mullvad Wireguard on the router.

You should probably contact support about it, this thread is about the AR300M which does not have this problem.

Well, I do have a GL-AR300M16 which does have this problem!

Message: Mullvad profile successfully created. But it’s not there! I see also that the router setup procedure created a new key in my Mullvad account. But no Mullvad profile is created/visible in the router setup.

Did you do a factory reset after updating to 3.100? I think I read to do that in the notes.

Thank you vvv, factory reset solved the issue :slight_smile:

1 Like

@lancer
It has been a couple of months since 3.100 showed up as testing. Do you anticipate releasing a new stable version of firmware for the AR300M soon?