Ar300m - repeater not working

I cannot seem to figure this out. No matter what wireless connection (home or hotel) I try to repeat, I loose the ssid. I need to hold the reset button for 3 sec to get the ssid back. It used to work fine and now nothing. I tried the newest firmware and still the same issue persists. Any ideas?

Maybe some unknown option set up in wireless.

Can you clean all the settings and try again? You can do this either using the reset button or UI.

I tried that and it still isn’t working. My other 2 units are fine but this one just stopped working. I always factory reset the unit after updating firmware.

I think I figured it put. Instead of holding the reset button for 10secs… I cleared the device through luci and all seems working.

Hi, I’ve got the “mango” version of the router and since updating to 2.26, I seem to be having the same issue. I have two clients, a laptop and an iPhone that will connect to the router (which is connected to the hotel router via WISP) that will keep dropping connection every few minutes or so. They will reconnect, no problem, but the connection is interrupted and lost fairly often.

Can you tell me how you reset this through luci so I can get up and running again? Thanks!

>>>Can you tell me how you reset this through luci

From GLUI > Advanced settings > (login to Luci) > System > Backup / Flash Firmware > Perform Reset.

Haha…well I probably could have figured that out myself :frowning: Thanks for the help!

I’ll post back whether this helps or not!

Reporting back on this as the issue is still happening…

After resetting my Mango (GL-MT300N) through the advanced interface in Luci and then setting up the device again…I’m still having the same issue. I have 3 devices connected to the router (laptop, shield tablet, iPhone) and all 3 will completely lose connection every minute or so. They typically rejoin the network about 10 seconds later but sometimes they don’t and you have to manually connect. I haven’t messed with any advanced settings…just set up SSID, security and password for the device…plus enabled WISP. No messing with any other crazy stuff.

Again…this only seems to be happening when I’m in WISP mode, piggybacking off of wireless access (WAN) from the hotel with one radio and broadcasting my own SSID/network (LAN) with the other.

I tested plugging in my phone to the router and using the tether feature. All three devices did not disconnect for the entire time I was running this setup (2 hours).

Any other help or troubleshooting would be appreciated. I didn’t seem to have these issues on the previous firmware release…so I’m hoping it’s just a bug in this round and will be remedied soon. The WISP feature was the biggest draw for me so hope it’s something easy to fix. Love this little router and want it to continue to improve!

Are you using WPA2? If so try setting it to WPA2/WPA. Worth a shot.

I experienced this when my ISP router was on channel 6, IIRC. I changed to channel 11 and the drop out on my AR300M (WISP) stopped. Obviously, this won’t help you if you connect to the hotel via WiFi, as you can’t change their channel but might help if you are wired to it (ie. change the channel on your Mango).

Do a “revert to factory default” and try again.

Check the signal strength of your main wifi and make sure the signal is good.

Check the channel and encryption method and post it here so that we have more info to consider.


Thanks for the suggestions, everyone…I’ve narrowed a few things down but the bottom line is I’m still having some issues.

When I tried troubleshooting again from my laptop, the laptop itself was having issues staying connected to the router - even when it was not connected to any WAN source…no WISP, Ethernet…nothing…just powered on so I could configure. It was dropping connection every minute or so, which I saw yesterday…but didn’t realize that was what was happening yesterday too. I could eventually get the device configured but had to be quick. In any event…It still dropped connection after getting it configured.

I changed the security to WPA2/WPA (was set to just WPA2) but it did not affect anything…still getting disconnects.

Changed the channel from Auto to 4 (I did a scan with my tablet and the hotel’s AP was set to channel 1)…still getting disconnects.

Did a full reset on the device and set it up again using the same settings as above…still getting disconnects.

Connected straight to hotel wifi from my laptop and checked for driver updates. New WLAN driver available for my Lenovo T450s - awesome! Maybe it’s just my laptop? Installed new driver and rebooted. Connected to Mango router and…disconnect. Sheesh :frowning:

Alright…so I turned on my iPhone’s wireless hotspot. Connected the Mango router to the iPhone (wirelessly - via WISP) to simulate WISP connection to hotel wifi. Have been connected without it dropping my laptop for the last hour. I even VPN’d back to my office (using my laptop’s VPN client, not configured through the router) and it’s working just fine.

So…I don’t know…I guess the Mango just doesn’t like the access point at the hotel. The hotel wifi signal in my room sucks (around -60db or so) which is why I wanted to use the WISP feature in the first place. So maybe the signal fluctuated and was too weak?

I still cannot understand why my laptop did not like staying connected to the Mango even when there was no internet connection and then why it kept dropping off while I was configuring and then when WISP’ing to the hotel wifi. But when connected to WISP via iPhone hotspot, it stays connected just fine.

Today is the last day of my work trip and troubleshooting internet stuff is really not what I want to spend my time doing (another reason I got the Mango - simple gui and setup), so I’m kinda done for now. I’ll be traveling again in a few weeks and will try everything again. Maybe another firmware update will be out by then and that could have an effect?

I’m curious if you have the ability to connect the Mango to the hotel via Ethernet (Wan to hotel)?

I do this in general when I can. I think it’s slightly faster.

Plugging in to an active Ethernet port is definitely my preferred method as well. In this case, I don’t have one in the room. I’ve noticed wifi-only rooms becoming more common in the last couple of years and have never had a device with the versatility of these little routers until now.

I know I talked about issues with my laptop but my phone, tablet and roku have currently been connected to the Mango, which is connected via WISP to the hotel AP, all without issue…

So I really don’t know what’s going on. Honestly it could be several things but my Mango may not like my laptop or vice versa at the end of the day.

I know I can always connect the laptop to the router with a cable…but the little Mango is currently hanging out in the bathroom, as the hotel AP is actually “louder” there and repeating to the rest of the room.

For all this messing around…it’s pretty sweet that this thing can do what it does. And for $20. I told a friend about them and he’s already purchased two haha. Really, great job with these little devices, guys. And the support seems to be strong as well.

By the way…we should all throw down some support for GL inet over at smallnetbuilder (I can’t find any mention of these in their forums) and continue to leave honest reviews on Amazon. Really happy with the device and want to see what future iterations can do!

Other suggestions

BIOS update

Lenovo Firmware Updates

Have you the same issue if you take the Mango and laptop to Starbucks etc?

@murdock57, thanks for your support.

There are some issues can cause wifi connection drop.

  1. When using the router as repeater while the signal is not good, the connection may drop.
  2. The mini router may have problem with some kind of routers while using repeater. We don't have a confirmed material. When the wifi chips are from different manufacturers, this happens more.
  3. WiFi from laptop could drop the connection. If using some very old laptop, connecting wifi maybe a pain.
  4. Some settings in the wifi configuration cause problems. We don't know what is the settings or how a user set the settings. But generally cleaning all the setting in the router solves most of the troubles.

I’ve been in some hotels where it just won’t work. No matter what I try I can’t get a successful connection. Not sure what it is… I travel quite a bit and there are some places were I just give up. With the 2.261 firmware I’ve found a big improvement in getting connected but there are still some that just won’t cooperate.