AR750 not working with sierra wireless


#1

I am using my AR750 with sierra wireless EM7511 via USB port.
I am using QMI mode. In command line uqmi -d /dev/cdc-wdm0 --get-current-setting, it could display IP address. However, OpenWRT can’t recognize my IP address and no internet access. Anyone know what to do? There is no log in system log.

In both GL.iNet Admin Panel and Openwrt panel, it will recognize it is connected. But IP address won’t show up.

Powered by LuCI openwrt-18.06 branch (git-18.196.56128-9112198) / OpenWrt 18.06.1


#2

By the way, my EM7511 works well with a different OpenWRT flavor (OpenMPTCPRouter)


#3

The EM7511 has PCIe Interface and you used a PCIe to USB adapter, right?

As far as I know Sierra uses a different driver which is not compatible with current firmware. Your other openwrt may have compiled the driver in.

The driver could be supported and I need to ask expert to have a check. If you could send logs that could be helpful. The output of the following command:

dmesg
logread
ifconfig -a

#4

Here is mine:

dmesg

 qmi_wwan 1-1:1.8: cdc-wdm0: USB WDM device
qmi_wwan 1-1:1.8 wwan0: register 'qmi_wwan' at usb-ehci-platform-1, WWAN/QMI device, 3e:xx:xx:xx:xx:xx
qmi_wwan 1-1:1.10: cdc-wdm1: USB WDM device
qmi_wwan 1-1:1.10 wwan1: register 'qmi_wwan' at usb-ehci-platform-1, WWAN/QMI device, 3e:xx:xx:xx:xx:xx
usbcore: registered new interface driver qmi_wwan
usbcore: registered new interface driver rndis_host
usbcore: registered new interface driver sierra
usbserial: USB Serial support registered for Sierra USB modem
usbcore: registered new interface driver sierra_net
usbcore: registered new interface driver option
usbserial: USB Serial support registered for GSM modem (1-port)
usbcore: registered new interface driver rt2800usb

ifconfig -a

wwan0     Link encap:Ethernet  HWaddr 3E:XX:XX:XX:XX:XX
          inet6 addr: fe80::3cb8:cfff:feff:a5b1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2742 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1266 (1.2 KiB)  TX bytes:334708 (326.8 KiB)

wwan1     Link encap:Ethernet  HWaddr 3E:XX:XX:XX:XX:XX
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Uqmi Checkup

root@GL-AR300M:/etc/config# uqmi -d /dev/cdc-wdm0 --get-serving-system
{
        "registration": "registered",
        "plmn_mcc": 302,
        "plmn_mnc": 720,
        "plmn_description": "ROGERS",
        "roaming": false
}

#5

Ok, I solved this problem by flash plain vanilla Openwrt 18.06.2 and install qmi related modules.