AR750S: 5GHz radio turns itself off

I honestly have no idea what is happening here, but all of a sudden, my 750S router keeps turning off the 5Ghz radio. I’ve tried resetting the router completely, reverting all configurations, but to no avail. Is this a known problem? It seems to have worked well for a while, but not any more.

Any ideas?

If you are running one of the testing firmwares, see if it happens on the latest release for the AR750s too.


is this perhaps the same problem as I have?

I upgraded both my AR750 and my AR750S to the latest 3.003 version, and so far so good. Stable, no issues with WiFi.


Just to confirm, been running with this for a month now, and pretty much rock solid. The AR750S is an amazing device, highly recommended!

The only thing high on my wish list would be an easily configurable setup (route tables I’d imagine) such that certain services like Netflix bypasses the VPN. The problem is that Netflix, and other services, will detect that I’m on a VPN, and refuse to serve content even though I’m still in the US. The “solution” is to turn off VPN, which I really don’t want to do on an insecure hotel network :-).

Those features is in our develop list, but we need more time to do it.