AR750S and AR750M Routers won't keep phone charged

I tried a search and didn’t find anything - which I presume means I’ve got something set wrong.

I have an ongoing problem with a pair of GL-iNet routers.
GL-AR750S-EXT
GL-AR750 (M) – Beryl

NEITHER of them will keep ANY of the cell phones charged – different phone manufacturers (ZTM vs Motorola) and different units – 2 DIFFERENT Motorola G7 Power.

I’ve had BOTH of these routers on power supplies from 2.0A to 2.4A to 3.0A. When plugged directly into ANY of the phones, the power supplies ALL provide power between .8-.9A and .2A, generally around .4A, easily keeping any of the phones charged.

BUT, when EITHER router is plugged in, the output from the USB Type-A port that connects to the phone drops to a maximum of .17A and drops to ZERO within a short time. The phone still sees it as “charging” but the amount is too low to even show on the meter and any of the phones I’ve tried discharges and goes dead within a couple days.

The AR750S is older, and it’s never kept the phone charged. I was told it was IMPERATIVE that this device be connected to a 2.4A supply in order to keep the phone charged. So I bought a couple and tried THREE of them. They all do the same thing. Work fine connected to the phone, but when connected the router will NOT keep the phone charged.

About 4-5 months ago I bought the Beryl ‘cause it was new, magically wonderful, and would work wonders… So far, the thing’s not a bit better than the old AR750S and it ALSO won’t keep the phone charged.

Is there some setting on or in these routers that I need to change so these routers WILL keep the phone charged? Firmware? Something else? I can’t believe I’ve got TWO of these things that are duds, so WHAT’s the secret to getting them to maintain the charge in the connected phones?

I have the same dilemma. Rather my AR750S-Ext is wonderful but my phone slowly loses charge through the day. I have been using it for wfh during covid, with the good 4g (sometimes 5g) signal I get, and this avoids me fighting for bandwidth with the home broadband.

(off topic but I have it set up for loadbancing and fail over, so if the phone goes or I unplug it, the router switches over to the home brodband)

I was considering the Beryl, as USB 3 has a slightly higher spec, but from what you say that won’t fix the problem.

I have also tried using various powered USB hubs/dongles on the phone but it fails to recognise the tether.

I suppose if you must have 24/7 then separate power for the phone and router and use wifi tethering (though this did mess up using wifi access from clients for me).

I just found I have a USB 3 Data and Power Y splitter cable and will see if that will work. The phone does tether, just waiting to see if it charges more than it drains.
https://m.media-amazon.com/images/I/61PS7SAXiFL.AC_SL1000.jpg

UPDATE
I have played about with things and used a wattage meter on the adaptor.

What I have concluded is that the limit on what the phone and router pulls is 7.7w at the wall and this was using a power adaptor that will push a lot lot more (not a fast charge one though). This charges the phone or at least holds it at the same level of charge.

The Y lead I am unsure if it does anything but I leave it in.

If, as well as tethering the phone, I force the phone to have its screen on at max brightness and not switch off, then the phone drains as the supply can’t keep up. If they switch off it holds its own. So things are on the edge.

If I plug the phone straight into the adaptor to charge it pulls over 10w alone. So the router is the limiting part here. AT 5v 7.5 w means it is drawing 1.5A, this is not a lot.

I did try a “smart” charger that will go a lot higher still but it made no difference, 7.7w was the highest draw.

I too have tried the volt/amp meter on the routers. On a 3A power supply, the phone by itself will draw around 1.3-1.9A, so mine’s getting somewhere around 6.5W up to 10.

Into the router, depending on the cable, I can get anywhere from about .48A, which won’t even boot the router, up to about 1.1A. I haven’t seen it draw over 7W, but either way, it’s appears it’s not passing enough to the phone.

On the OTHER side of the router, the most I’ve seen out of the router is .4A, so 2W, and the current drops to .17 very quickly less than 1W, and then to zero.

If you have the phone set up to stay on as long as it’s connected, as the instructions say to, there’s no way the router is going to keep it charged.

Well after a few days using it, my phone is gaining charge not loosing it now. The only thing that is different from when I started this and it lost charge through the day is I am using a dedicated power supply. All the cables etc… are the same and I stopped using the Y splitter.

Summary: I switched to a 25w/5A charger that puts out up to 2.4A per socket. And as I said earlier I measure up to 7.7Watts at the wall.

Did some research about this.

In order to charge phone, your need to have a charing IC which negociate with the phone about the current it can accept.

Unfortuantely the router is not a charge so it does not have charing IC. In such situation, the max current the phone accept is 0.5A.

That would match what I’ve seen - .48A. Unfortunately, it drops very quickly, and usually shows 0A charging. For example, after 4 days plugged into the AR750S, the Moto G7 Power (very large battery), which was at 100% when plugged in, is down to 69%. According to the phone, at the rate it’s receiving current, it would take 14 HOURS to get it fully charged.
The OTHER phone, connected to the 750M (Creta) router has been on for 5 days and it’s down to 49%. That phone does NOTHING else - no calls, no camera, nothing - screen never comes on. It just does data.

0A charging but still have data right? maybe it is a phone’s choice?

At the moment, the Moto G7 is down to 28%, and the other phone on the Creta is down to 31%. I DON’T think it’s the phones refusing to be charged…

SO FAR, the “solution” has been to pull the plug on the routers at least once/week. The reboot gets them charging the phones again. After 12-14 hours, the Moto G7 will be up to 69-70% and the phone on the Creta will be up to 48-49%.

It appears to me the routers start at their normal, anemic .5A, quickly taper down to about .17A, then to ZERO, and then NEVER start charging again. Or pass through such a minuscule amount of current that the phones slowly drain the batteries.

I have just hit the same issue with a Mi10T lite tethered to a slate. Got it all working fine but the phone won’t stay charged even with battery saver etc. The router just doesn’t have the power.

I’m wondering if PD (Power Delivery) devices would help here. I have a few gadgets lying around including on the go adapters but none of them are any good. The PD device I have is PD/ETH splitter and as we know, we need usb…

I WILL solve this even if it kills me…

Old thread but I piked up an Slate in the recent sale an had the same problem where the phone was slowly discharging while tethered.

I resolved the issue by using an Amazon Basics 3.0 USB Hub with 2.5A external power attached the the Slate USB2.0 port, and connecting the phone to one of the hub’s USB ports. Charging is slow but it actually charges rather than discharging so all good.

I tried powering Slate from the hub as well as the phone but that causes the phone to continuously start/stop charging. Not sure what was happening but powering the Slate separately seems to be the way to go.

-PG

1 Like