AR750S Can't Update packages

I have updated to 3.201 from 3.105 both with saving settings and not, I’ve tried both ways.

I cannot update add on packages or install Luci or File Sharing.

It appears to update, but I only get the 266 packages that are already installed.

When I go to install file sharing or Luci I get the error in the screenshot below

only 266 packages is not correct.

Can you ssh to the router and use opkg update and check the output?

Did you ever make changes in opkg config?

I don’t recall making any changes at all. It was a new install of 3.105 then Upgrade.

About 3 months ago I had to update firmware after I bricked it and had to uboot restore. That could have something to do with …something? I got confused with the NOR vs some other version, but eventually got it working again, It was really bricked…

opkg update returns:

*** Failed to download the package list from

*** Failed to download the package list from

*** Failed to download the package list from

Collected errors:


I can download those files in a browser tho. The only actual changes i made on 3.105 was ssh in and issuing the samba update commands:

sed -i 's/security = share/security = user/' /etc/samba/smb.conf.template

/etc/init.d/samba restart

This is quite strange. Can you download the files on the router directly using wget?

No, it throws this error:

root@GL-AR750S:~# wget
Downloading ‘
Connecting to
Connection error: Invalid SSL certificate

So I just updated to 3.201 tonight.

root@GL-AR750S:/tmp# opkg list-installed | wc -l

So same number of packages as @bobbyj8866 . I am able to run “opkg update” though.

Since my setup is pretty vanilla, I have not tried to install any new packages

Not sure what is the reason.

The correct output should be like

So…should I try a uboot restore with latest firmware?

I think you can just "revert firmware“ and clear everything.

No need to do via uboot.

I’ve done that action several times now. Is it possible I used the wrong NAND / NOR file the day I bricked and tried to restore various ways?

Is there a way to update whatever ssl certificate the routers uses? or to download the packages manually and copy them over to the router?

I reverted to a previous firmware 3.105-104 and OPKG update works properly. Odd!

When Up then upgrade to latest 3.201 firmware, opkg update gives the SSL error.

I got it working, one must in my network enable VPN polices for all processes. SOLVED.