AR750s Slate bridge/repeater

Just received this week my new AR750s Slate from Amazon. I’m trying to set up. I’m having problem with the repeater mode.


  • Cable /WAN from the telco in the closet, in the middle of the apartment
  • In the closet an Actiontec wireless modem belonging to the telco:
  • I have my computers (1 desktop + 1 laptop) + 1 printer in my office (actually just a room). I’m hiding behind the AR750s Slate. I connect to the wan via wireless 5ghz
  • The rest of the family have their own laptops/tablets but they need to print to my printer: hp network printer: (when AR750s Slate in repeater mode)

If I set the AR750s Slate to repeater, then everybody can connect to their respective destination incluing the printer but then I cannot access the AR750s Slate to configure it.

I did an arp-scan and I can’t find the AR750s Slate when in repeater mode for updates or configuration changes…

How do I access the AR750s Slate when in repeater mode?

Thank you

If you log into the Actiontec, you will see that the Slate will have an IP from it. If you access that IP in your browser you should be able to connect to the GL UI.

Thank you. I’ll try it during the week.

That didn’t work.

  1. I switched to extender mode
  2. On the Actiontek (the telco), I can see that the slate has been assigned ip address: It also says: GL-AR750S Connected. It also has the correct mac address (from underneath the slate)

My IP address is:

When I enter in my browser. I get: ‘Unable to connect’

I have to do a full reset 10 seconds, power off, power on and then can get in the slate with address:

Any further suggestion?

Thank you

In repeater mode, I have found that you can still access the Slate, but you have to do so at as it is still listening at that address.

To accomplish that you will have to set the connecting device to manually connect to it without using dhcp. It is usually easiest to do that over Ethernet but I have used WiFi as well. You will need to set your PC/Laptop to a fixed IP ( with a gateway of and usually a netmask of (or 24).

Thanks. I’ll try it over the weekend. Too many important zoom meetings that I have to participate to change any of the network settings.