AX1800 Static IP Wireless

I want to use my AX1800 to connect to a network that doesn’t have DHCP, all the devices use static IPs and use it as a wireless access point.

Looking at setting the IP address it only allows me to change the 3rd octet and I need to be able to change all of them. Also need to be able to turn off DHCP on the AX1800.

I’ve tried to change the IP via LuCI but it doesn’t accept the changes. It will count down 90 seconds, then “Failed to confirm apply, waiting for rollback”

EDIT: To clarify what I’m trying to do.

I have devices that have static IP addresses that I need to connect my laptop to, to make configuration changes. Usually, I will set a static IP on my laptop and connect my laptop directly to the device and I can communicate with it. I’m trying to use the AX1800 as a wireless access point so I don’t have to be tethered to the equipment.

End EDIT

While testing - if I change the network mode to “access point” it tries to get an IP from a non existent DHCP server. Then I have to reset the device to regain access to it via the default IP (192.168.8.1).

Do you want to connect your laptop to AX1800’s wifi using DHCP? Or you want to set up static IP on your laptop as well?

If using a different subnet is OK, can you do this:

  1. Set up static IP on AX1800’s WAN and keep it in router mode
  2. Connect your laptop to AX1800’s wifi and get IP address 192.168.8.x. Try access your “device” using its static IP.

Thanks for the help.

Doing this, I can ping the device with my laptop having a 192.168.8.*/16 address. The device has a 192.168.1.1/16 address. I can’t connect to it, but I can ping it. It may be a port or firewall setting in the AX1800.

Also, I had to connect the device to the WAN port before it would give me the option of changing it to static. Is there a way to change the WAN port address without having it connected?

I was able to modify the firewall settings through the advanced (LuCI) menu and now it works.

Thanks for the help.

Any chance you can summarize or screenshot the change to the firewall you had to make? I’m less versed in networking and want to use this as a temporary hotspot for PLC commissions.

Danny,

Ironically, that’s what I’m using it for!

After I’ve used it a bit, I discovered that i didn’t need to make firewall changes. So, from factory reset:

Connect your pc via ethernet through a LAN port
Setup the wifi.
Disconnect ethernet
Connect to wifi
Connect ethernet to WAN port
Configure the WAN port for static ip and set it to the subnet your plc is on. (Ex: if your plc address is 192.168.1.1, then you set the WAN to 192.168.1.[unused ip])
Disconnect the ethernet from your laptop and connect it to the plc.
Your laptop will have a 192.168.8.* address, but you’ll be able to access the plc.
On Rockwell I have to use the ethernet driver, instead of the ethernet/ip driver in RSLinx to get it to work.

I hope this helps

1 Like

Yes it does! You are amazing for responding so quickly too. I had just gotten it to work by using the LuCi to manually set it as static, but that’s much less hassle next time! Tyty!