AX1800 unable to update AdGuard


auto-updating AdGuard to version 0.107.8 fails. Anyone figured out how it works? Is updating router repository necessary at first?

I am using FW 3.214 and AdGuard version 0.107.7.


Did you update Adguard Home previously? Adguard Home save a backup when upgrading, and the backup file may cause a shortage of space.
You can use rm -r /etc/AdGuardHome/agh-backup/ to remove the backup file.

Thanks for your answer.

I did not update AdGuard previously. Anyway, there was only 9% free space available - 5.49 mb in total. After using your command there is 37% free space available (22,52 mb). Anyway, the update failed again :frowning:

The size of the ADGuard Home installation package should be around 10 MB. I think this size should be enough.
Are there any error messages when the upgrade fails?

Anyway, I tried it manually via SCP and it worked. It was a bit tricky as there is no official SCP client available for mac (I used CrossOver) but now everything is okay.

Is there a urgent need to upgrade?

A GL-iNet router is an embedded device. The kernel, the distribution (collection of packages) and the drivers are bundled and tested.
Any change of the kernel, the packages or the drivers are not tested. It is not like a Desktop PC, where you can up- and downgrade your graphics driver or office suite, without interfering another part of the system.

If i would be interested in upgrading AdGuard to the newest version on any firmware, and it works, nobody will/can guarantee that it will do it the next time.
Some times you’ll need manual to resolve the dependencies. Sometimes you’ll need to alter the install scripts. sometimes you need to recompile the whole package against your firmware. There is no ‘one for all’ solution.

but because i am just a user and don’t know anything, here a little more official statement about this topic: [OpenWrt Wiki] Upgrading OpenWrt firmware using LuCI and CLI