B1300 HOWTO disable u-boot tftp auto update

Hi,

How can I disable auto update by tftp ?

I’ve tried setting serverip to null and autoload=no in u-boot environment.

U-Boot 2012.07 [Chaos Calmer 15.05.1,r35193] (Apr 13 2018 - 13:54:46)

Thanks.

I don’t think it can be disabled.

If you don’t run tftp server, it won’t update automatically.

Thank you kyson-lok, that’s my experience, just wondered whether I was overlooking a u-boot environment switch.

I want to prevent accidental and/or malicious OpenWRT update via TFTP auto update, so have disabled in source.

Here is the uboot for B1300, you can modify the source. https://github.com/gl-inet/uboot-ipq40xx