Beryl 1300 "wrong key" connecting to iPhone hotspot

Beryl 1300 travel router, iPhone 7p.

When using the wi-fi repeater, I’m able to find the SSID of my iPhone’s hotspot. No matter what I enter for a password, it says “wrong key.”

I’m able to connect to this hotspot with other devices.

Having looked around a bit, it sounds like this might be an existing bug that’s at least 5 months old? Wondering if a fix is coming soon.

If not, I’d like to know if any of your other travel routers are free of this defect.

thank you,


Is it possible you are entering it incorrectly? Maybe you got a “sticky” key. Try copying the password from the admin panel & pasting it in directly.

Also make sure to turn off “Private address” in the Wi-Fi options on iOS. It has caused some issues in the past for me.

If it still doesn’t work, you could try the beta firmware. I don’t know if this issue was reported before, or a known issue, but it’s possible it got a (silent) fix.

You can download beta’s from here, mind you they might be unstable.

Just try 3.215 snaphost for MT1300 Beryl.

Unfortunately none of these worked. I double checked the key. My iPhone doesn’t have a private wi-fi address (OS is new, but the phone is old, an iPhone 7p). Even tried the beta firmware. No dice.


Seems some folks in this reddit have a similar issue (further down the page):

Oh, I see now that “snapshot” is different from beta? I’ll try that next. Thank you.

Snapshot update didn’t work. (I suspect it’s no different than the beta version since it’s the same file size)

Getting frustrated. I’m also having problems with wifi dropping, as is mentioned elsewhere on this forum. Turning off “auto scan” didn’t help.

Starting to wonder if it’s time to return the device. :frowning:

Starting to wonder if I have a defective device.

I’ve discovered the hot spot issue, then wi fi dropping, and now I’m seeing that my VPN speeds (when I can keep wi fi up) are down to like 20% of my connection speed (the app version of this same VPN provider are at about 80%).

This is on different wi fi networks even using different laptops.

Seems like way too many problems for a device that is supposedly so popular.

Whe you use vpn the speed will drop. That is limitation of the hardware.

For wrong key, can you set the 2.4G WiFi to H20 and try again?