Beryl AX-3000 Repeater Mode *STILL* not working

I just upgraded my Beryl AX-3000 to 4.2.2 release 1. I’m currently at home with a pretty straight-forward wifi setup. The AX-300 still is having MAJOR problems connecting to my home wifi in repeater mode. I continually get “timeout in response…”. I have tried both 5ghz and 2.4ghz. No captive portal (obviously!) I finally got connect to the 5ghz network, and it the promptly dropped and reconnected automatically.

Can someone -please- tell me what I need to do to get this device to work reliably?? Or, should I simply ask to send it back for a refund?

I am unable to attach the logs as the it appears they are to large to copy here.

Is it works fine before you upgraded the firnware?

Could you send me some log from GL-MT3000?
What is the model of your home router?

No, I’ve had very little success with repeater mode almost everywhere. At a hotel with a captive portal it has never worked. I was hoping that this latest update would make things better.

I’m on the 4.2.2 r3 beta and don’t have any issues with the repeater function connecting to Asus routers.

For me, this got fixed in a January snapshot.

I’m not sure how to do this because the log is more than 32k characters. When I try to message it to you I get an error message.

It is a Technicolor TC7203O modem/router

You can share the log via

The latest snapshot solved this for me. Couldn’t get anything to work yesterday now it seems to be working as normal.