Beryl AX as Access Point

Just received a Beryl AX router as I needed an access point for a Windows 11 PC with only an Ethernet port.

I didn’t see anything specific to use it as an access point, but sounded like repeater mode is the same.

I have it connecting to my AmpliFi Alien router, and the BerylAX is connect to the PC with an enet cable on the LAN port. Seems to work with one issue on Windows 11.

Since I want to ONLY use this as a single PC access point I have a few questions…

  1. How do I turn off the ability for anyone else to connect OR see the BerylAX as it seems to be discoverable (turn of SSID brodcasts in repeater mode if possible??). I can see the BerylAX’s network on other devices, so not a good thing really.

  2. Running Windows 11 Pro and can’t seem to get the network to show other systems. I have a couple of computers that show up on each other network browser, both connected to the AmpliFi router by wifi, which is the same as the BerylAX.

The one on the BerylAX does not seem to be discoverable on Win11. In fact it comes up in Windows as a PUBLIC network. BUT even when I allow full access to public networks it will not find any other machine on the same network IP range. I can see the AmpliFi router but that’s it, no PC’s, no Printers like the other WiFi connected (to the main router) does. Again all have the same network ranges, for all connected.

Is this something to do with WISP security that is mentioned in the set up documents?

It’s pretty close to working, just need a bit more to get it all to work.

I didn’t grab the SW version, will grab that tomorrow if needed.

Login to LuCi (that is advanced web GUI) then go to wireless tab click edit on your SSID, you can see an option to hide it.

1 Like

Since your Windows11 accesses the Internet through Beryl AX router, then it considers it public side hence disabling (for security reasons) the network discovery features.


Troubleshoot Tip:

  • disable the firewall on Windows 11 and the other network computers

  • then try to ping the other computers on your network to make sure there is a network level connectivity.

Will give Luci a go, the broadcast of the SSID is the least of the issues it seems.

Thanks, and will see how it works.


Set all that up in W11 once I got the system connected to the BerylAX. I had done the switch to a private network and allowed network discovery, pretty much standard as I add a machine. Might be something else missing, but was pretty much what the link to the online guide showed as to what I did.

Also all of my other machine are ping-able, so I can hit them. Also in testing, if I type in the actual machine address like //alienware-15 I can access the machine, so may the issue might be something on the win11 side.

Still working!

Thanks again for your help on this.


Is Win11 on the same network?

Yep, I can get to the one of the machines by typing the explicit path like //alienware-15. I may have also found that I have no way to access the machine since it’s only set up with Windows Hello and not a saved local password so may be rejected. Working on that first. I think the AX is not a problem here, more screwy windows networking set up.

All machines are Win11 pro or Home and can ping all other machines both ways. Still working on some things to see if it works :wink:


Ok, found the issue. By default in Extender mode the AX will NOT forward port 445 and port 139 which seems to be needed for windows SMB for file share and discovery.

I went into LuCi and added the rules there as I could not figure out how to do it in the AX web interface.

It worked right after that.

So a couple of things to help the next person -

Check to see if SMB is enabled on your windows machines. I enabled all as SMB 1 protocol was not by default. This MAY NOT BE NEEDED. It’s also stated that SMB 1 should not be used, I might try to turn it off and see but hating to tamper with it now it’s all working.

In the Advanced interface (LuCi) I added in the firewall a port forward rule from WAN to LAN with ports 445 and 139 enabled to the LAN port.

I can’t remember if I updated the LuCi firewall rules before switching to Repeater mode, but I’m pretty sure I did since once you flip it into repeater mode you lose access to the routers web interfaces.

That seemed to do it.

One thing that I don’t like is that I can’t change the full IP of the AX to access the web interface, it’s painful to set the static IP up to be able to access settings. Not sure if their is any other way to get to the web interface once in repeater mode. Would be a big time saver if their was!

So to summarize if you are using the repeater mode (Access point from a WiFi) you and using windows you may need to open up ports 445 and 139 for it to discover the computers on your windows network.

See cautions on SMB 1 protocol as well.


Glad you fixed it. However you had never mentioned that you were using in Extender mode!

Describing the issue correctly can greatly help others to help you!

I did mention repeater mode in the initial request, which I believe is correct, I may have botched the last message calling it extender mode. I think the manual uses both, including access point. It’s confusing to say the least or I’m just getting it wrong :smile:

Again, thanks for the help.


What do you mean by full IP?

If I have a LAN address of my current router set to something like and using the AX in repeater mode for an access point, I can’t set the AX to work on that with the web interface, I have to reset my IP to a static IP on a computer to a 192.168.8.x range to be able to check / change settings. You can change the AX’s second to last number from 8 to something else but not the rest of it’s IP. So if I did put it on the 192.168.122.XXX local LAN I have, it would conflict with the main router as the AX would also be on (as you can’t change the 1).

So if I could set it to as an example, I could access it from my computer or local LAN and check/change settings.

I don’t know if there are other reasons you can’t change the full address to access the web interface (or I may have missed it) but I’m not sure you can as it seems you are fixed at only the range of 192.168.XXX.1

Again, in repeater mode it also tells you to set up a static IP on you machine in that range or you can’t get to it.

Hope that makes sense.


Try this:

  • Login via SSH
  • Edit /etc/config/network using vi
  • Run: /etc/init.d/network restart


Worked like a champ. I can now hit the web interfaces from my regular connection at
Setting the web interface should be an advanced option, seems really useful if you don’t want or know how to use linux. I did give it a try in LuCI but I think it reverted the change after it could not connect to (or so the message said). Not a big deal as the manual update worked like a champ.

Starting to really love this router!

Can’t thank you enough for sticking with the little fixes to get me going, again a huge thank you.


i think you can also from Luci:

I think that is where I tried to change it, but once saved it popped a message that it was trying to verify it was working and couldn’t connect (since I changed the address) it said it would revert. Don’t remember all the wording, but when I rebooted it was back on for the web interface.

Not a huge deal as your method worked like a charm. I will try this on the next one I get, the BerylAX seems to be a solid performer and working really well once I figured out (with your help) some of the kinks in my set up.


Yes, through the LuCi it reverts back so that a user doesn’t lock himself out!

It’s a Linux OS after all so enjoy the world of open source (and the pain of bugs :sweat_smile:)