Beryl AX - Can't connect Vpn WireGuard Client - Version 4.4.6

  • Version 4.4.6
  • Firmware Type: release2

Trying to connect Beryl AX to my Opal router on home server.

It was working fine over the last couple weeks. Now that I have arrived somewhere else. All of a sudden, today the beryl ax was not connecting to the internet via wifi. I connected through tether and it worked fine. Connected then to my VPN server, then worked fine.

I saw Tailscale application so I decided I’d try it out. Tried connecting and then I couldn’t figure out a way to direct traffic via exit node so I stopped Tailscale. I then tried connected to my WireGuard Client vpn and now not working anymore.

I did reboot, reset to factory settings, everything. Nothing works.

The only thing that works again is connecting to my wifi after reset of router.

Here are the logs below. This set up was working fine until today. Unfortunately I do not have access to my home router since I am out of the country.

Please, can someone help me out? I’d appreciate it.

Logs below:


Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):    * Zone 'wan'
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):    * Zone 'guest'
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):    * Zone 'wgclient'
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):  * Set tcp_ecn to off
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):  * Set tcp_syncookies to on
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):  * Set tcp_window_scaling to on
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):  * Running script '/etc/firewall.nat6'
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):  * Running script '/etc/firewall.swap_wan_in_conn_mark.sh'
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):  * Running script '/var/etc/gls2s.include'
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):    ! Skipping due to path error: No such file or directory
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):  * Running script '/usr/bin/gl_block.sh'
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978):  * Running script '/etc/firewall.vpn_server_policy.sh'
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978): Failed to parse json data: unexpected character
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978): uci: Entry not found
Sun Jan 28 20:05:03 2024 daemon.notice netifd: wgclient (19978): cat: can't open '/tmp/run/wg_resolved_ip': No such file or directory
Sun Jan 28 20:05:03 2024 daemon.notice netifd: Interface 'wgclient' is now down
Sun Jan 28 20:05:03 2024 daemon.notice netifd: Interface 'wgclient' is setting up now
Sun Jan 28 20:05:03 2024 user.notice mwan3[20071]: Execute ifdown event on interface wgclient (unknown)
Sun Jan 28 20:05:04 2024 user.notice firewall: Reloading firewall due to ifdown of wgclient ()
Sun Jan 28 20:05:08 2024 daemon.notice netifd: wgclient (20072): Try again: `vc64325.glddns.com:51820'. Trying again in 1.00 seconds...

It looks like it’s not resolving your GL DDNS to whatever IP is on your Opal (WG Server).

Hardwire while troubleshooting. That’ll help determine if it is/is not Wi-Fi related.

1 Like

I have the same issue, and exact same log output. Did you find any solution?