Beryl AX & Slate AX Teather Not Working With MR5100

I get the device is connected but cannot access the internet error connected via USB. The MR5100 runs via 192.168.1.1 and both the Beryl & Slate run 192.168.8.1 the cable internet comes in Ethernet via 10.0.86.10 so no overlapping IP issues. The MR5100 has internet validated via its WIFI also via hard wiring into its Ethernet port. I can access the MR5100 landing page when connected via the Beryl or Slate and when doing so I can see the RX/TX updating in Luci so they are defiantly communicating but its like the internet is not being passed between the two. I made sure the USB cable is good to go as well as this same MR5100 and cable tether perfectly with my R7000 running fresh tomato. Out of curiosity I removed my MR5100 and plugged in my MR6400 and that one worked fine so I feel like the driver being used for the MR5100 is screwed up I’m not sure. I’ve reset the Slate/Beryl, reflashed the firmware with reset settings, flashed the firmware via uboot even tried downgrading a few versions as well as downloading the latest betas and snapshot still same results. All settings are default on the Beryl/Slate. I’ve even changed the multi-wan to httpping and turned status tracking off still cannot get internet via the tethered MR5100.


image
Is your Internet connection connected according to the listing expansion chart?

The MR6400 is in working fine.But MR5100 can’t access the network properly?

You can catpure data package with tcpdump on the lan and wan of Beryl & State.

Hello lizh,

My apologies I dont know what is meant by “listing expansion chart”. However to explain my network layout I’ve created a diagram. Mind you I am only using the Beryl or Slate not both at the same time and the MR5100 or MR6400 not both at the same time just for clarity.

When enabling tethering here is the syslog from connecting to the failure however during the brief time it is connected there is still no internet during that time. I’ve even removed the cable internet and attempted to run only off tether and have the same issue. If i disable the tracking for up/down to eliminate any ping vs. http i still have the issue except the error message on the GUI goes away and no internet remains.

Could you explain how to do the tcpdump i’ve installed the plugin but are not sure after that what to do.

“Fri Jul 14 07:31:48 2023 daemon.notice netifd: Interface ‘tethering’ is enabled
Fri Jul 14 07:31:48 2023 daemon.notice netifd: Network device ‘eth3’ link is up
Fri Jul 14 07:31:48 2023 daemon.notice netifd: Interface ‘tethering’ has link connectivity
Fri Jul 14 07:31:48 2023 daemon.notice netifd: Interface ‘tethering’ is setting up now
Fri Jul 14 07:31:48 2023 daemon.notice netifd: tethering (25516): udhcpc: started, v1.33.2
Fri Jul 14 07:31:48 2023 daemon.notice netifd: tethering (25516): udhcpc: sending discover
Fri Jul 14 07:31:48 2023 daemon.notice netifd: tethering (25516): udhcpc: sending select for 192.168.1.4
Fri Jul 14 07:31:48 2023 daemon.notice netifd: tethering (25516): udhcpc: lease of 192.168.1.4 obtained, lease time 43200
Fri Jul 14 07:31:48 2023 daemon.info avahi-daemon[5035]: Joining mDNS multicast group on interface eth3.IPv4 with address 192.168.1.4.
Fri Jul 14 07:31:48 2023 daemon.info avahi-daemon[5035]: New relevant interface eth3.IPv4 for mDNS.
Fri Jul 14 07:31:48 2023 daemon.info avahi-daemon[5035]: Registering new address record for 192.168.1.4 on eth3.IPv4.
Fri Jul 14 07:31:48 2023 daemon.notice netifd: Network alias ‘eth3’ link is up
Fri Jul 14 07:31:48 2023 daemon.notice netifd: Interface ‘tethering’ is now up
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: reading /tmp/resolv.conf.d/resolv.conf.auto
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: using only locally-known addresses for domain test
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: using only locally-known addresses for domain onion
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: using only locally-known addresses for domain localhost
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: using only locally-known addresses for domain local
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: using only locally-known addresses for domain invalid
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: using only locally-known addresses for domain bind
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: using only locally-known addresses for domain lan
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: using nameserver 10.0.86.10#53
Fri Jul 14 07:31:48 2023 daemon.info dnsmasq[13441]: using nameserver 192.168.1.1#53
Fri Jul 14 07:31:49 2023 user.notice mwan3[25531]: Execute ifup event on interface tethering (eth3)
Fri Jul 14 07:31:49 2023 user.notice mwan3[25531]: Starting tracker on interface tethering (eth3)
Fri Jul 14 07:31:50 2023 daemon.info avahi-daemon[5035]: Joining mDNS multicast group on interface eth3.IPv6 with address fe80::2a0:c6ff:fe00:0.
Fri Jul 14 07:31:50 2023 daemon.info avahi-daemon[5035]: New relevant interface eth3.IPv6 for mDNS.
Fri Jul 14 07:31:50 2023 daemon.info avahi-daemon[5035]: Registering new address record for fe80::2a0:c6ff:fe00:0 on eth3.*.
Fri Jul 14 07:31:51 2023 user.info mwan3rtmon[2546]: Detect rtchange event.
Fri Jul 14 07:31:51 2023 user.notice firewall: Reloading firewall due to ifup of tethering (eth3)
Fri Jul 14 07:32:31 2023 user.notice mwan3[27881]: Execute ifdown event on interface tethering (eth3)
Fri Jul 14 07:32:32 2023 user.notice firewall: Reloading firewall due to ifdown of tethering (eth3)
Fri Jul 14 07:32:33 2023 user.info mwan3track[25846]: Detect ifdown event on interface tethering (eth3)
Fri Jul 14 07:32:38 2023 user.notice mwan3track[25846]: Interface tethering (eth3) is offline”

1

After being puzzled by this for days I swapped sim cards between the 5100 & 6400 then the issue persisted with the 6400 and the 5100 worked so I determined it was an issue with the SIM card not the GLINET routers. I called my service provider and after several escalations they “reset” my account then re-pushed the firmware to the 5100 and re-provisioned the line again as soon as that was done all started working as expected.