Beryl (GL-MT1300) doesn't go to uboot

Hello, I’ve tried flashing openwrt firmware into my beryl device and suddenly I lost access to the wifi and web interface. After a couple of hard resetting I think I may have bricked the device.

Now, I tried to go to uboot but I’m stuck in the step where I have to hold the reset button while plugging the power cord it blinks like 5 times as shown in the video but after that it just turns off instead of white lights. I can’t access the uboot interface either after changing the ipv4 settings.

Also let me add a few more details:

  • I use Windows 10 (Killer ethernet controller)
  • It shows unidentified network
  • Default gateway is missing when executing ipconfig /all on cmd unless I specify it on ethernet properties but inaccessible in either way “192.168.1.1 took too long to respond.

Have you set your computer to static ip 192.168.1.2 ?

I apologize for the late reply, yes U changed my computer static ip to 192.168.1.2 and It didn’t work, I also tried setting default gateway to 192.168.1.1 it didn’t work either

You did change that for the ethernet network interface, right?

Every interface has its own settings.

You need to attach the serial port log so that I can determine the cause.

If you don’t have a uart tool or can’t take your router apart, you can ask for help by emailing support@gl-inet.com