Beryl (GL-MT1300) no SSID

Beryl (GL-MT1300) worked fine a few days ago. Now i’m observing that SSID is not showing to any devices.

  1. have tried the factory reset - still no SSID showing
  2. debricked Beryl with uboot few times with recent firmware update - no SSID showing
  3. debricked using older firmware - no SSID showing

uboot showed LED was flashing, any idea why Beryl broke down or any ideas how to fix this issue?

thanks.

Hi,
you only mention the problem with SSID. Does this mean that you still have access to the router ( Gl Web Interface) via an ethernet cable?

Hi Smith, I tried to connect the GI web Interface (http://192.168.8.1) with an Ethernet cable plugged however I was not able to connect.

then changed the internet protocol version 4 to (192.168.1.2) and tried to connect to 192.168.1.1 and 192.168.8.1.

do you have any other suggestion how to access the router? thanks

Hi,What did you do before the ssid disappeared?What is your latest firmware version?

Did not do anything, it was running fine but out of the blue could not access the router. I have set to auto-update the firmware but saw the latest 3.215 was released in September and my router stopped working in December. so it was not related to the version.

but for debrick tried with 3.215 and 3.211

Can you flash version 4.x and test?

Flashed with beta version openwrt-mt1300-4.1.0-1107-1667792228.bin but still no SSID showing under Wi-Fi option

Can you export the log?

Also ssh to the router and get the output of this command

iwinfo

I have downloaded putty and followed some of the steps in this doc. but not able to connect. " Network error : Connection time out"

I did the following

  1. turned off my wifi
  2. plug-in lan cable from the motherboard to Beryl router in Wan port
  3. do I need to change anything on ethernet 2 properties under IPv4 ( like to 192.168.8.1)
  4. connected to hostname 192.168.8.1: 22
  5. checked cmd ipconfig that the address was 192.168.8.1

think maybe my steps connecting to router with lan cable is wrong.

Hi,
for ssh over ethernet you must be sure that your computer’s ip is on the same network as the your router’s ip. If the router’s DHCP is still functioning, connect via Ethernet cable, you will receive an IP address from the router automatically. If you have OS Windows, you can check it with the command ipconfig -all, if you see an IP from the range 198.168.8.XX and as a gateway an IP 192.168.178.1, then the router’s DHCP is still working, go to the SSH step, if not, you have to set computer’s IP address manually.
SSH Access via powershell use the command: ( you can copy/paste)
ssh root@192.168.8.1
if the ssh service on the router is active, after the key exchange you will be connected automatically if no password has been set.

The Ethernet cable should be plugged in to connect the Beryl LAN port and the computer (motherboard?) LAN port.

I do not work for and I am not directly associated with GL.iNet

thanks for all your help so far. just wanted to say happy new year!

I’m still trying to export Berly log by ssh over ethernet cable.

  1. connected Berly Lan Port to computer Lan port
  2. checked under network connection - Ethernet status: auto config for Ipv4 is 168.254.162.246 and yes-DHCP enabled

do I now have to change the IP properties for IPv4?

1 Like

This means that the router does not give IP address. What is the LED status?

LED status normal blue light.

Try setting the computer LAN to IP 192.168.8.10 and gateway IP 192.168.8.1, then see if you can access 192.168.8.1.

Solid blue means the router is in booting process. It is not working yet so cannot issue IP address.

It should be flashing blue or solid white.

results_Capture

still not able to access 192.168.8.1

Does your pc has multiple Internet connections? Can you disconnect other connection and only connect to the router?

Also check if you have vpn on your pc. Disable it if you want to access the web panel.

I suddenly see the Beryl SSID, and was able to login using wifi. I had a quick look at the log and refreshed the last updates were from oct 14, 2022.

refreshed the log and exported.
logread.zip (20.9 KB)

checked again after an hour the SSID has disappeared again.