Beryl/MT1300 & 100Mbps devices not working

Hi, I have a Beryl (GL-MT1300) that has been great as a wireless travel router the past few years. It is up-to-date with release firmware 3.215.

Recently I have been using it in a lab environment with some older equipment that only have 100Mbps ports on them. If I connect the equipment to the Beryl directly, it sort of sees the equipment, and lists it in the client list (assigns IP, displays MAC address). The equipment cannot communicate to any other devices on the network, and from the equipment’s perspective, it does not have any IP configuration. Setting the equipment to manual IP assignment is reflected in the Beryl dashboard, but the equipment is still not able to communicate.

If I insert another switch between the 100Mbps device and the Beryl, then everything starts working.

The Beryl specs list claims: “Ethernet Speed 10/100/1000Mbps”.

Should I expect 10/100Mbps devices to actually work on the onboard ports? Is this issue limited to the Beryl model, common to all GL iNet products, fixable in firmware, tested regularly & just my unit, other?

Thanks for considering!

Can you try the 4.x version firmware?
If the problem still occurs, are you able to provide a log?

Can you try to ping the clients on your pc when conencted to MT1300?

I know some clients can only work in some subnet. Not sure if this is your case.

Thanks @yuxin.zou and @alzhao!

  • I will try the beta firmware, but would like to confirm that I can roll back to production (3.215) easily (including config) if necessary.
  • It would be great if the sticky at the top of the troubleshooting forum included details on how to collect a log.

Regarding subnets - there is no different IP configuration; only the addition of an external switch. All subnets etc. are the same with/without the external switch.

If the GL-MT1300 router has a LuCI → Network → Switch page, then it should display the LAN and WAN ports that are connected and at what link speeds and duplexes.

If there is no Switch page, then log in via SSH and try running the following commands for the information:

ethtool lan0
ethtool lan1

I do not work for and I do not have formal association with GL.iNet

Interesting, thanks. The LuCI => Network => Switch page does indeed see the device as 100baseT
full-duplex, but the device cannot get a DHCP address nor communicate if I manually set up IP and subnet. I’ll dig into this further on Monday.

Here are some other items you can try:

  1. Check the System Log (logread) on the GL-MT1300, just after you plug in the LAN port, for any errors or unusual messages.
  2. Try changing to a different CAT5e or better Ethernet cable.
  3. Try manually setting a static IP address on the Beryl, instead of using DHCP, to see if it communicates.
  4. Try plugging in a different computer, tablet or other device with a 1000Mbps Ethernet port and that uses DHCP to see if it gets an IP address.

Is the beryl the gateway and the only dhcp on the network?