Beryl MT3000 Repeater does not connect

Hey there,

I just got the MT3000 for travel.

Unfortunately it worked well at home but the repeater resets without a shown failure on connection.

I rolled back 2 versions in total after reading some topics here, but no luck.

I attached the two log files (didn’t Safe with the newest unfortunately but it was the same)

Tethering works fine.

Logs .zip (52.0 KB)

1 Like

it shows Failed Reason 2 (Previous authentication no longer valid).

What device is your ap? It may have compatibility issues with Beryl and I will forward it to the developer for retest verification.

Do you have access to this ap? You can try to set the ap to low compatibility, and then connect to see if it can be connected.

1 Like

It’s some Hotel Wifi, even without captive Portal.

iPhones, MacBook, Google Chromecast HD and the Video Babyphone are working with it.

Try to discover it with the Macbook later.

I got the newer MT3000 to get rid of compatibility issues :sweat_smile: I hope that’s not the case. It’s only my Travel Router and it worked fine with my Wifi 6 UniFi with WPA3. There is nothing configured for easier compatibility.

Hi Heimdall:

Would you like to try a repeater using openwrt’s clean firmware?
GLinet uses mtk’s original closed source wifi driver, perhaps openwrt open source driver has better compatibility, we are also collecting data to determine whether openwrt open source wifi driver can be adopted.

I’m seeing the same problem on my home router (ASUS RT-AX88U). Repeater works fine on 2.4GHz, but not 5GHz. Just got the MT3000 today, but I did update the firmware to the latest.