Beryl repeatedly rebooted when connecting to 2.4 GHz hotel Wifi

I recently got a new Beryl, using stock glinet firmware. I use it as a travel router till now it worked fine.
Now I am in a new hotel and wanted the Beryl to connect to its 2.4 GHz Wifi. After doing the usual Scan and connect the Beryl rebooted (checked with the luci interface). I tried a few times, my laptop was able to connect to the WLAN but the Beryl rebooted after connection attempt. I then connected the Beryl to the 5 GHz Wifi which worked fine.

I now connect to 5GHz WLAN from Beryl with my devices (because I got used to having the Beryl connect to 2.4 GHz) and the Beryl to the 5 GHz hotspot as well.

The power adapter is the original adapter, which has and does currently work well.

But why did the Beryl reboot repeatable when trying to connect to the 2.4 GHz Wifi? How can I obtain logs and send to glinet in a private way?

There is a firmware that can save logs when router crash. Can you try?

I may have found the issue.
the Wifi name has a “2,4 GHz” in its name, I think the single quote (comma) is the issue…
Currently I am connected to this WiFi, I am on newest testing firmware 1012. This WiFi is not listed in Known WiFI Networks but it is shown on the admin panel. @alzhao

The system should be able to deal with , and ’

Can you check /etc/config/wireless and find the ssid of the repeater.

ssid' likethis should be in the format ssid'' likethis . It will use two ’ to replace ‘’

The name is:

option ssid ‘HOTELXYZ 2,4 GHz _3’

Seems this should not be the problem.


as there is no reboot with the newest testing firmware, only not listed in known WiFi Networks, is there a way to pull logs?

Use command “logread”.

I sent a logfile to

Did anyone reply to you? I cannot find any email about this. What is the email from which you send the email? You can pm me your email address.

The solution was to install the newer beta firmware as new wifi drivers (?) were in there