Beryl VPN Issue

I’m using a Beryl Router in a remote location with Wireguard/VPN activated. If the internet service drops, the Beryl auto closes the connection (as a protection, I’m guessing) The problem is that I now need to travel 1 hour out of my way to switch the VPN back on to get the router to work again.

Is there a way to stop the Beryl from blocking the connection when the connection/VPN drops. It’s not critical to have the VPN working 100% of the time, If I could connect remotely when the VPN is down and re-connect - this would save a two hour trip! Does anyone have any ideas to do this? thanks.

Have you enabled VPN → Internet Kill Switch? If so, then disable it.

First, upgrade to 3.211 firmware.

Second, enable Goodcloud access. In vpn policy make sure Goodcloud does not go through vpn.

Then, when your vpn breaks, you can ssh to the router via Goodcloud.

Yeah, disable kill switch is a good bet, but that’s strange, when I lost internet with the flint, it auto reconnected once internet was back up.