BL1300 limit on number of interfaces?

Hi I am using a GL1300 as an additional Wifi Access Point on a network with multiple SSIDs and associated VLANs for secure separation of traffic. Using the LuCI interface I have successfully set up the configuration, and most of the SSIDs work except one. The client initiates a connection to the SSID which seems to work, but then it gives up.

I have noticed something odd in the LuCI / Network / Interfaces / Interface Overview page, that the interface for this network does not come up, and it does not obtain an IP address via it’s DHCP client. Here is an example of the page output:

Network Status
IFVLAN120 () br-ifvlan120 Uptime: 2d 5h 46m 17s
IFVLAN150 () br-ifvlan150 Uptime: 0h 0m 0s
IFVLAN80 () br-ifvlan80 Uptime: 2d 5h 46m 17s
IFVLAN90 () br-ifvlan90 Uptime: 2d 5h 46m 17s
WAN eth0 Uptime: 0h 0m 0s
WAN6 eth0 Uptime: 0h 0m 0s
LAN () br-lan Uptime: 2d 5h 46m 20s

As you can see it is the VLAN150 which does not accept connections, the other 3 SSID/VLAN combos work just fine. I have checked and they appear to be configured in a similar manner, including the bridge between the VLAN Interface and the 2 Wireless Networks (1 per radio).

They are all set to Bring Up on Boot so I am wondering if there is some other reason why the interfaces do not come up. Is there a hardware or software limitation on the number of interfaces that can be configured?

Please let me know if you want any other config detail to assist in diagnostics
Thanks for taking the time to read through and respond to my issue.

The first question I’d ask is if you’ve got something connected to the “WAN” port of your router. It’s OK if you don’t, just helpful to know what is expected to be up and not.

Your description suggests that there is a mismatch between your /etc/config/wireless and your /etc/config/network

The output of of the following (redacting your IP/MAC addresses if you consider them sensitive) might also be helpful:

ip link                # Which interfaces are known and their state
ip addr                # Assigned addresses
brctl show             # Software bridges established

Thanks @jeffsf for suggesting where to look. There are a lot of entities in my config, so the ‘logs’ below are somewhat long. I am not using the WAN ports as I only have a single ethernet running into my main switch, therefore they are fine to not be up.

cat /etc/config/wireless

config wifi-device 'wifi0'
	option type 'qcawifi'
	option macaddr 'my:ma:ca:dd:rs:84'
	option hwmode '11g'
	option country 'GB'
	option channel 'auto'
	option txpower '20'

config wifi-iface
	option device 'wifi0'
	option network 'lan'
	option mode 'ap'
	option blockdfschan '1'
	option ifname 'ath0'
	option encryption 'psk2+tkip+ccmp'
	option key 'mypsk1'
	option ssid 'ssid1'

config wifi-device 'wifi1'
	option type 'qcawifi'
	option channel 'auto'
	option macaddr 'my:ma:ca:dd:rs:85'
	option htmode 'VHT20'
	option txpower '23'
	option country 'GB'
	option hwmode '11ac'

config wifi-iface
	option device 'wifi1'
	option network 'lan'
	option mode 'ap'
	option blockdfschan '1'
	option ifname 'ath1'
	option encryption 'psk2+tkip+ccmp'
	option key 'mypsk1'
	option ssid 'ssid1'

config wifi-iface 'wif120r0'
	option network 'ifvlan120'
	option mode 'ap'
	option ssid 'ssid120'
	option encryption 'psk2+ccmp'
	option key 'psk120'
	option device 'wifi0'

config wifi-iface 'wif120r1'
	option device 'wifi1'
	option network 'ifvlan120'
	option mode 'ap'
	option ssid 'ssid120'
	option encryption 'psk2+ccmp'
	option key 'ssid120'

config wifi-iface 'wif80r1'
	option device 'wifi1'
	option network 'ifvlan80'
	option mode 'ap'
	option ssid 'ssid80'
	option encryption 'psk2+ccmp'
	option key 'psk80'

config wifi-iface 'wif150r1'
	option device 'wifi1'
	option network 'ifvlan150'
	option mode 'ap'
	option ssid 'ssid150'
	option key 'psk150'
	option encryption 'psk2+tkip+ccmp'

config wifi-iface 'wif80r0'
	option device 'wifi0'
	option network 'ifvlan80'
	option mode 'ap'
	option ssid 'ssid80'
	option encryption 'psk2+ccmp'
	option key 'psk80'

config wifi-iface 'wif150r0'
	option device 'wifi0'
	option network 'ifvlan150'
	option mode 'ap'
	option ssid 'ssid150'
	option key 'psk150'
	option encryption 'psk2+tkip+ccmp'

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'auto'

config interface 'lan'
	option ifname 'eth1'
	option type 'bridge'
	option _orig_ifname 'eth1 ath0 ath1'
	option _orig_bridge 'true'
	option proto 'dhcp'
	option hostname 'glinet-WLAN-AP3'
	option ieee1905managed '1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option hostname 'GL-B1300-123-5G'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 1 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '1'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '2'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '3'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '4'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '5'
	option mode 'dscp'
	option status 'enable'

config switch_vlan 'swvlan120'
	option vlan '120'
	option vid '120'
	option ports '0t 3t 4t 5t'
	option device 'switch0'

config switch_vlan 'swvlan80'
	option vlan '80'
	option vid '80'
	option ports '0t 3t 4t 5t'
	option device 'switch0'

config switch_vlan 'swvlan150'
	option vlan '150'
	option vid '150'
	option ports '0t 3t 4t 5t'
	option device 'switch0'

config switch_vlan 'swvlan90'
	option vlan '90'
	option vid '90'
	option ports '0t 3t 4t 5t'
	option device 'switch0'

config interface 'ifvlan120'
	option proto 'dhcp'
	option type 'bridge'
	option ifname 'eth1.120'

config interface 'ifvlan80'
	option proto 'dhcp'
	option type 'bridge'
	option ifname 'eth1.80'

config interface 'ifvlan150'
	option proto 'dhcp'
	option type 'bridge'
	option ifname 'eth1.150'

config interface 'ifvlan90'
	option proto 'dhcp'
	option type 'bridge'
	option ifname 'eth1.90'

ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: miireg: <> mtu 0 qdisc noop state DOWN mode DEFAULT group default
    link/generic
3: ifb0: <BROADCAST,NOARP> mtu 1500 qdisc hyfi_pfifo_fast state DOWN mode DEFAULT group default qlen 32
    link/ether nw:ma:ca:dd:rs:db brd ff:ff:ff:ff:ff:ff
4: ifb1: <BROADCAST,NOARP> mtu 1500 qdisc hyfi_pfifo_fast state DOWN mode DEFAULT group default qlen 32
    link/ether ab:ma:ca:dd:rs:04 brd ff:ff:ff:ff:ff:ff
5: gre0@NONE: <NOARP> mtu 1476 qdisc noop state DOWN mode DEFAULT group default
    link/gre 0.0.0.0 brd 0.0.0.0
6: gretap0@NONE: <BROADCAST,MULTICAST> mtu 1462 qdisc hyfi_pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
7: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN mode DEFAULT group default
    link/ether cd:ma:ca:dd:rs:92 brd ff:ff:ff:ff:ff:ff
8: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc hyfi_pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether my:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
9: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc hyfi_pfifo_fast master br-lan state UP mode DEFAULT group default qlen 1000
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
10: wifi0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 2699
    link/ieee802.11 my:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
11: wifi1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 2699
    link/ieee802.11 my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
12: br-ifvlan120: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
13: eth1.120@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan120 state UP mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
16: br-ifvlan80: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
17: eth1.80@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan80 state UP mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
18: br-ifvlan90: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
19: eth1.90@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan90 state UP mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
20: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
29: ath0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UNKNOWN mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
30: ath01: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan120 state UNKNOWN mode DEFAULT group default
    link/ether ot:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
31: ath02: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan80 state UNKNOWN mode DEFAULT group default
    link/ether yr:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
32: ath03: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan150 state UNKNOWN mode DEFAULT group default
    link/ether hd:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
33: ath1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UNKNOWN mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
34: ath11: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan120 state UNKNOWN mode DEFAULT group default
    link/ether ot:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
35: ath12: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan80 state UNKNOWN mode DEFAULT group default
    link/ether yr:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
36: ath13: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan150 state UNKNOWN mode DEFAULT group default
    link/ether hd:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
37: br-ifvlan150: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
38: eth1.150@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan150 state UP mode DEFAULT group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff

ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: miireg: <> mtu 0 qdisc noop state DOWN group default
    link/generic
3: ifb0: <BROADCAST,NOARP> mtu 1500 qdisc hyfi_pfifo_fast state DOWN group default qlen 32
    link/ether nw:ma:ca:dd:rs:db brd ff:ff:ff:ff:ff:ff
4: ifb1: <BROADCAST,NOARP> mtu 1500 qdisc hyfi_pfifo_fast state DOWN group default qlen 32
    link/ether ab:ma:ca:dd:rs:04 brd ff:ff:ff:ff:ff:ff
5: gre0@NONE: <NOARP> mtu 1476 qdisc noop state DOWN group default
    link/gre 0.0.0.0 brd 0.0.0.0
6: gretap0@NONE: <BROADCAST,MULTICAST> mtu 1462 qdisc hyfi_pfifo_fast state DOWN group default qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
7: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN group default
    link/ether cd:ma:ca:dd:rs:92 brd ff:ff:ff:ff:ff:ff
8: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc hyfi_pfifo_fast state DOWN group default qlen 1000
    link/ether my:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e695:5678:9012:c184/64 scope link
       valid_lft forever preferred_lft forever
9: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc hyfi_pfifo_fast master br-lan state UP group default qlen 1000
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e695:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
10: wifi0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 2699
    link/ieee802.11 my:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
11: wifi1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 2699
    link/ieee802.11 my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
12: br-ifvlan120: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.120.3/24 brd 192.168.120.255 scope global br-ifvlan120
       valid_lft forever preferred_lft forever
    inet6 fe80::e695:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
13: eth1.120@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan120 state UP group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
16: br-ifvlan80: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.80.3/24 brd 192.168.80.255 scope global br-ifvlan80
       valid_lft forever preferred_lft forever
    inet6 fe80::e695:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
17: eth1.80@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan80 state UP group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
18: br-ifvlan90: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.90.2/24 brd 192.168.90.255 scope global br-ifvlan90
       valid_lft forever preferred_lft forever
    inet6 fe80::e695:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
19: eth1.90@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan90 state UP group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
20: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.8.247/24 brd 192.168.8.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fe80::e695:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
29: ath0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UNKNOWN group default
    link/ether my:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e695:5678:9012:c184/64 scope link
       valid_lft forever preferred_lft forever
30: ath01: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan120 state UNKNOWN group default
    link/ether ot:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::1234:5678:9012:c184/64 scope link
       valid_lft forever preferred_lft forever
31: ath02: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan80 state UNKNOWN group default
    link/ether yr:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ec95:5678:9012:c184/64 scope link
       valid_lft forever preferred_lft forever
32: ath03: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan150 state UNKNOWN group default
    link/ether hd:ma:ca:dd:rs:84 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f095:5678:9012:c184/64 scope link
       valid_lft forever preferred_lft forever
33: ath1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UNKNOWN group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e695:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
34: ath11: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan120 state UNKNOWN group default
    link/ether ot:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::1234:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
35: ath12: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan80 state UNKNOWN group default
    link/ether yr:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ec95:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
36: ath13: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan150 state UNKNOWN group default
    link/ether hd:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f095:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
37: br-ifvlan150: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e695:5678:9012:c185/64 scope link
       valid_lft forever preferred_lft forever
38: eth1.150@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-ifvlan150 state UP group default
    link/ether my:ma:ca:dd:rs:85 brd ff:ff:ff:ff:ff:ff

brctl show

bridge name	bridge id		STP enabled	interfaces
br-ifvlan120		7fff.e4956e44c185	no		ath01
							ath11
							eth1.120
br-ifvlan150		7fff.e4956e44c185	no		ath03
							ath13
							eth1.150
br-ifvlan80		7fff.e4956e44c185	no		ath02
							ath12
							eth1.80
br-ifvlan90		7fff.e4956e44c185	no		eth1.90
br-lan		7fff.e4956e44c185	no		ath0
							ath1
							eth1

I’ll need to go through this on a bigger screen later on, but a couple things caught my eye:

option encryption 'psk2+tkip+ccmp'

First is that allowing TKIP is generally not needed for any reasonably modern client and it reduces the security of your wireless. Second is that it curiously is associated with your troublesome 150 SSID/VLAN. psk2+ccmp would be my recommendation here. That may clear everything up.


config interface 'ifvlan150'
	option proto 'dhcp'
	option type 'bridge'
	option ifname 'eth1.150'

It’s strange to me to have the router’s IP address assigned by DHCP, if it needs one at all. If you’re bridging the wireless clients (and perhaps wired clients) on the VLANs to a network where other services and the default route exist, at least for me, there is no need for the bridge to have an IP address at all. My bridged interfaces used for AP-only functions generally end with

        option proto 'none'
        option auto '1'
        option delegate '0'

delegate is somewhat undocumented, but as I recall it reduces the IPv6 IP assignment. It “works for me” in my applications. Its function can be traced down through /lib/netifd/proto/dhcp.sh

I do have a dedicated management VLAN for my boxes, with a static IP. None of my “in-production” OpenWrt boxes has outside Internet access. If your needs are different, you can chose an approach that suits your security requirements.


option channel 'auto'

This is a placebo. hostapd generally picks the lowest numbered channel and, as far as I know, never budges from it. Picking a channel with reduced interference often gives better results.


	option _orig_ifname 'eth1 ath0 ath1'
	option _orig_bridge 'true'

This is legacy temporary clutter, which can be removed. It was the way that LuCI saved previous settings. This temporary storage has been moved to another location on OpenWrt master, at least. Not a problem, but cleans up your files.