Brume 2 is dead, cannot access uboot

Hi there,

This afternoon I had to restart my network equipments and after that the Brume 2 just stopped working.
I tried to reset it first, no luck.

Then I tried to access the uboot, no luck too.

  1. Followed the tutorial:
    Debrick via Uboot - GL.iNet Docs (
  2. When I connect my computer to LAN port, it does not connect at all (windows shows no connection, ipconfig shows no interface connected). Looks like LAN port is dead.
  3. When I connect my computer to WAN port, it shows that a connection is stablished, so WAN looks fine.
  4. Even though I had set the computar IP address to and followed the tutorial to get on uboot (press reset, power it on, wait until the lights pattern changes and then releases the reset button), I cannot access uboot at

Is there anything else that I can do?

Just to be sure:

Often theres a small detail I always forget in order to get it to work.

Have you removed all cables and only connected one cable on the lan port?, I think uboot wil not run if there was atleast one other cable connected.

On the Flint ive used uboot on the lan port many times, but I did noticed people having success on the wan port though I think the docs explain it better, I would expect the same for brume 2.

I confirm that there is only one cable connected to the router at a time.
I tried to plug the cable into LAN port first but as that port looks to be dead the only alternative I have is using the WAN.

You need to hold reset button, have it plugged into usb-c, then plug into outlet while still holding the power reset button.

Sorry, I might have writen it wrong but that’s exactly what I did.

Just wanted to make sure. I just did it on my Brume 2 it flashes 5 times then goes solid white.

So something I have noticed is that with Many GL.iNet power supplies and powering on, and it is stated in the guides, you always want to plug the power cable into the device then plug the power cable into the outlet. If you pull the cable from the device while still powered on you can get a spark.

Mine flashes 5 times then goes solid white too.
Did you tried that on WAN port?

Please note, for Brume 2 uboot, pls use LAN port.

As the WAN port is 2.5G which needs extra driver, it does not work in uboot.

So if LAN port does not work, you cannot flash using uboot.

If you are sure the LAN port is damaged, please return to us to investigate. This is the first case so I’d like to get it back to check.

Pls DM me for returning the product, or just write to us using email support at

1 Like

No did it on the LAN.

If you are not doing so try the uboot in a private window.

If that does not work flush the DNS.

But the LAN port could be dead.

1 Like