Brume 2 VPN Policy to Each Router Client Devices

Hi All.

Current setup: Modem Ethernet wire into Brume 2 WAN and Brume 2 LAN Ethernet wire into Router WAN.

I’ve logged into the Admin panel and configured the VPN Client to utilize “VPN Policy Base on the Client Device” however only one client (My Router) shows up. I suppose that is because of my setup but I’m completely clueless to how I can implement a way to display all my Router Client Devices into Brume 2. I believe there’s just one missing piece and I’m unsure.

Please assist.

The Brume 2 does not know the specific clients that are connected to your Router LAN because the clients are NAT’ed to the same IP address of the Router WAN.

The Brume 2 is a router, so do you need to have another Router behind it? If you connect the clients to a switch behind the Brume 2, then the Brume 2 will know the clients.

I do not work for and I am not directly associated with GL.iNet

It is recommended that you set your Wi-Fi router to access point mode.

Alternatively, you can change the connection method and connect the WAN port of the Brume 2 to the LAN port of the Wi-Fi router. Then enable Drop-in Gateway on the Brume2.

Thank you! It worked when I reconfigured my Wi-Fi router to access point mode Out of curiosity, is it more efficient or better to do the alternative “Drop-in Gateway” method? I know it’s subjective but I’m curious if it’s a popular pick.

I don’t think it will work better.
Some users are not comfortable changing their ISP router for various reasons, such as carrier restrictions. Drop-in Gateway is designed to allow such users to use the features on our devices as well.