Brume (GL-MV1000) as Wireguard appliance

Hello all,

sorry for my stupid question but, what is the best practice to use an GL iNet Hardware as an Wireguard appliance without the other things btw. nat, routing firewall etc. Is there perhaps a documentation etc. Unfortunately, Wireguard is not available in AP mode. My goal is that the Brume really only acts as a Wireguard VPN appliance in my network.

Thx for help.

1 Like

Sorry now Wireguard only works in Router mode.

What is your application scenario?

I wanted to do the same to set up my GL-MV1000W as a VPN appliance on my LAN that I can route through selectively, but not constantly and not for all devices.

I was able to do this this years ago with an old Linksys router, running DD-WRT, and switching the default gateway on my PC using the NetSetMan utility.

I think you can set up the GL-MV1000 as a router with WireGuard and connect the WAN ports of both it and your main router directly to 2 ports your Internet modem/router. The LAN subnet would be the same for both and your main router would be the only DHCP server.

I am still testing, but it seems to be work as a OpenVPN appliance connecting only the LAN port, not the WAN port. It should probably also work with Wireguard, but Brume is already fast with OpenVPN.

I used the following as a guide:

I am able to use NetSetMan (free for personal use) to switch my IP settings between my main Internet router and the Brume VPN router.

Hi TandK,

I know it is a bit late response, but it is quite easy to setup, even with the Brume in router mode. I have set it up as a wireguard server and DNS server with adGuard Home. It works like a charm:

If you want only the wireguard:

On the Brume:

  • activate the wireguard server
  • configure port forwarding in firewall for wireguard:
    protocol: TCP/UDP,
    ext zone: WAN,
    ext port 51820,
    int zone: lan,
    int IP <local IP address of Brume (in my case>

On your normal router:
IP forwarding on the firewall:
protocol: TCP/UDP,
ext zone: WAN,
ext port 51820,
int zone: lan,
int IP < ext IP address of Brume (in my case and make sure brume as a static IP on your lan)>
int port 51820

You also have to change the wireguard client config with your real wan ip address.

I hope it works for you.