Brume W forgets wifi after several hours

Brume W first day out of the box, after 6 hours in repeater mode no longer connects. On iPad it sometimes see’s the Brume wifi but says “unable to join wifi” (when connecting) or the Brume wifi does not show up in the wifi list at all.
Tried short reset/ network repair (button on side) for 4 seconds. Same symptom, no change.
Eventually did a long reset at least 10 seconds and wifi was now connectable and problem gone. I thought the long reset would reset the Brume to factory settings, (passwords) but it acted like a network reset in that nothing changed (passwords etc) other than the network was now connectable and internet available.
One spurious thought is I enabled Adguard sometime during the initial 6 hours while it was working. Could be nothing but other than that it was completely vanilla.

When there are sudden issues like this out of the box, i might say the memory is corrupt in some way.

Follow the debrick guide from here:

Use the 3.104 firmware from here:

Thanks for the suggestions good to have. Brume was delivered with firmware 3.104
Day two experience was the same. After some point no internet access and can no longer connect to Brume wifi (unable to join wifi). I failed to mention that Brume is running OVPN client (Nordvpn). Not exactly vanilla as I stated.
When the failure occurs it appears the OVPN is trying to connect endlessly. I’m assuming this creates the situation where I can not connect to the Brume wifi (unable to join wifi message). This also prevents from connecting to admin (
Power cycling the router seems to be the best cure for the problem. Wondering if this could be caused by the specific VPN Server at Nord so deleted/ selected a new configuration profile. so far 4 hours later all is working as expected.
Also programmed the switch to turn VPN off and on hoping if this problem occurs again I have a way to disable VPN (avoiding the endless VPN reconnecting) and then connect to the Brume wifi

Day 3 not one problem with Brume after deleting specific Nordvpn server configuration and loading another.
Problem solved.