[Brume2 GL-MT2500] Don't use VPN for router itself


I have a VPN client set up with policy based on client device. This is working correctly. However I noticed that after setting up tinyproxy on the router, requests get sent out via the VPN. Is it possible to avoid this? I’d like only the clients set up in the policy to be sent to the VPN, the router itself shouldn’t be included in such policy by default.

Thank you

You can try setting the tinyproxy process’s user group to nonevpn. The code we use to control the process from VPN is as follows:

sed -i "/procd_open_instance/a procd_set_param group nonevpn" /etc/init.d/gl_mqtt