[Bug] Beryl (GL-MT1300) 4.3.6 Firmware only repeats 5GHz Ch 36

Was using the previous 3.xxx firmware in my beryl in my homelab located in the garage. Was working connecting fine to my downstairs AP running 5Ghz AC on channel 100 VHT180. The upstairs AP is similar but set to channel 36. Downstairs having a stronger signal it would prefer that BSSID.

So after updating the MT1300 to the current 4.3.6 version (erased previous config) when I searched for a repeater on 5GHz it only is able to find and connect to the AP running on channel 36. No other channels seem to work. I then tried changing channels on the upstairs and downstairs AP and confirm this is the case.

Appears to be a bug

Cheers,
Barry

Hi booz:

I did a retest.

repeater a channel 36 AP on 3.216, then upgrading to 4.3.6 release2, it was found that it could scan bands 1 and 4 (36-48, 149-161);

Can you provide the config of wireless?

cat /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '2g'
        option country 'US'
        option disabled '0'
        option htmode 'HT40'
        option legacy_rates '0'
        option vendor_vht '1'
        option channel '9'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'GL-MT1300-dd6'
        option encryption 'psk2'
        option key 'goodlife'
        option wds '1'
        option isolate '0'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
        option band '5g'
        option htmode 'VHT80'
        option country 'US'
        option disabled '0'
        option legacy_rates '0'
        option channel '36'
        option hwmode '11a'
        option require_mode 'ac'
        option channels '36,40,44,48'
        option txpower '20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'GL-MT1300-dd6-5G'
        option encryption 'psk2'
        option key 'goodlife'
        option wds '1'
        option isolate '0'
        option disabled '0'
        option hidden '0'

config wifi-iface 'guest2g'
        option device 'radio0'
        option network 'guest'
        option mode 'ap'
        option encryption 'psk2'
        option key 'goodlife'
        option ssid 'GL-MT1300-dd6-Guest'
        option guest '1'
        option disabled '1'
        option wds '1'
        option isolate '1'

config wifi-iface 'guest5g'
        option device 'radio1'
        option network 'guest'
        option mode 'ap'
        option encryption 'psk2'
        option key 'goodlife'
        option ssid 'GL-MT1300-dd6-5G-Guest'
        option guest '1'
        option disabled '1'
        option wds '1'
        option isolate '1'

config wifi-iface 'sta'
        option mode 'sta'
        option device 'radio1'
        option network 'wwan'
        option ssid 'my_ssid'
        option bssid 'xx:xx:xx:66:DD:C3'
        option key 'my_password'
        option encryption 'psk-mixed'
        option ifname 'wlan-sta0'

I tested your configuration and found that everything worked fine;

I can scan and connect the ap of band1 and band4;

If you restore factory Settings, will it work again?

Are you using release 3 or release 2? Regardless in release 3 I was able to repeat the upper channels:

root@GL-MT1300:/tmp# uci show wireless.radio1.channel
wireless.radio1.channel='153'

Also, you may want to edit the above as your SSID and PW are shown in clear text.

Ok, but if you have two APs with same SSID but different channels, the previous version 3.xxx would show them all but this 4.3.6 is only showing me the channel 36 AP not the channel 100 AP. Can you see this?

This is with version
4.3.6
release 3

Edit, what country does your router believe to be in?

Some countries don’t use channel 100. It might be a reason for it. It might be the same reason my slate ax doesn’t wrongly see channel 149.

In the US, at least, channel 100 is part of DFS which could be getting blocked if you are nearby radar or it could be a bug in 4.3.6 for DFS if the router supports it.

Ooooh, I missed this.

Channels 52-68 and 100-140 are DFS nearly everywhere

and Opal doesn’t support DFS. (Ok, I have to wake up still. Does Beryl support DFS?)

Beryl AX does, mt1300 I think so as well. I should know this because I own this one but because my 5G is the tethered band atm, I can’t look at the drop-down for wireless frequency selection.