Bug: HWNAT is not working from OpenWrt - only from LuCI

Today I noticed some of my wireless clients cannot access the Internet when their VPN is enabled, although they were connected to the Spitz router. I immediately suspected the Routing/NAT Offloading feature because I recently played with it.

I investigated the issue of enabling Routing/NAT Offloading (a.k.a HWNAT and Network Acceleration) on the latest beta OpenWrt versus LuCi. I found out that enabling the the Network Acceleration feature under OpenWrt does not get reflected on LuCI and vice versa!

As a workaround and to avoid the conflict, I enabled this feature from LuCI and disabled it from GL OpenWrt. Please note that this feature is called “Network Acceleration” in OpenWrt as opposed to Routing/NAT Offloading in LuCI.

Enabling the Network Acceleration from GL OpenWrt does not work:

uci show | grep offload

uci: Entry not found

After Enabling it form LuCI:

uci show | grep offload


GL engineers: can you please test and and confirm what I listed above? In addition, can you please clarify the difference between: Network Acceleration, Routing/NAT Offloading and Hardware NAT (HWNAT)? It seems to me all are referring to same thing! If so, let’s fix these confusing names to be streamlined in both OpenWRT versus LuCI!

Are you using MT300? The HNAT driver needs to use MTK’s private code and is not supported by the kernel, so the firewall acceleration option will not work.

I am using Spitz AX 5G

Actually the HWNAT works when enabled from luCi. But it does not get enabled when it is done from OpenWrt.

Are you using our release firmware? Or do you compile firmware with openwrt source code?

Yes latest beta openwrt it’s already mentioned above

It’s been a while since I posted this bug? Do you have any updates regarding it ?