[BUG] Multi-WAN does not respect priority order

GL-AX1800 v4.5.0.

Multi-wan configuration is not respected.

When you restart the router, it returns with the repeater as the main one.

The main one is Ethernet, but when you restart the router it connects to the repeater and makes the repeater the main one.

Please try GL-AX1800 v4.5.0.Beta.
https://dl.gl-inet.com/?model=ax1800&type=beta

The problem continues in version 4.5.

I have already opened a ticket reporting the same problem.

How are upgrade? If you are keeping settings then this maybe the issue. Do not keep settings instead create a backup in LuCi, Upgrade not keeping settings then load the backup config file. You can also change the settings for Tracking method,Tracking reliability,Ping interval, Interface down, Interface up, Metric in Multi-Wan just click the gear icon.

I don’t keep updates.

And Multi-WAN is not working as it should.

Even, out of nowhere, a message appears stating that there is no connection, either on the repeater or on the ethernet.

The repeater connection freezes and I have to remove the repeater and connect it again.

I’m waiting to see if they resolve this issue. There is also a speed problem. As soon as you connect it to the repeater and leave it as main, it reaches 150MB. Hours later the connection is below 30MB.

Have you tried upgrade by Uboot? I have Link Aggregation so it breaks the GL.iNet Multi-WAN So I am using LuCi Multi-Wan where it did not work correctly till I did a Uboot upgrade.

I tried updating via Uboot.

I think it killed the router system hahaha.

I can’t connect to the router.

There is a stopped light.

I updated the firmware using Uboot.

I configured the router.

But the problem of not respecting the order in multi-wan continues.

The multi-wan is all buggy.

When the repeater connects to the router, it changes the multi-wan order automatically and becomes the main connection.

“The Interface is connected, but the internet can’t be accessed.”

There is also the problem of crashing.

Out of nowhere, the repeater displays this no connection message and it is not possible to access the repeater’s GL-INET control panel.

Have to remove the repeater and add it again.

Sometimes there is a problem with both interfaces and sometimes with one.

And what is the Tracking method,Tracking reliability,Ping interval, Interface down, Interface up, Metric in Multi-Wan just click the gear icon.


Hello, the problem we know so far is that the priority does not take effect when the vpn is enabled.If the page often shows that the interface is not networked, but in fact the interface is networked, try adjusting the sensitivity option of multiwan, setting it to low or customizing it to a longer detection period (such as 10s).If the problem still exists, you can enter the background through ssh and enter the following command:

echo 3 > /proc/gl-kmwan/debug

Wait for a period of time (1-2min), and then send the relevant log to us for troubleshooting.
Thanks

The problem occurs without VPN too.

I tested with and without.

The repeater takes over and remains as the main network regardless of the multi-wan configuration.

You can ssh into the background and then use the following command:

uci show kmwan |grep metric

Check the priority of your configuration

Captura de tela de 2023-10-10 23-45-14

Thank you, I just looked at the code and we did have a problem fixing this issue

Hello, if you want priority to take effect, after each relay connection, you must also ssh into the background and execute the following command:

/etc/init.d/kmwan restart

Or after connecting to the relay, readjust the priority on the multiwan page.We will fix the problem as soon as possible,Thank you very much for your feedback.

1 Like

Thanks. I’ll do it.

Looking forward to the firmware with the fix.