BUG: Package update fails with OPENVPN enabled

From ssh I can not update packages or ping google.com (accessing GL-AR300 remotely via VPN. Is there any solution to get it working?
Thanks for any answer (I saw a similar topic in May 2022 but no answer found on the forum)

ping: bad address ‘www.google.com

what vpn protocol? which vpn service?

Do you have normal Internet when you connect to the router?

Regardless of the above, you can always try to set up custom dns server on the router to and, or use encrypted dns settings.

Thanks a lot for the prompt answer,

Currently I can only access remotely via the VPN (the device is far from my home) but everything seems to be OK as I have a device connected to the LAN port and this device can access Internet and send emails through the GL-AR300M.
My configuration is also OK with DNS set to

Ping to is working
PING ( 56 data bytes
64 bytes from seq=0 ttl=116 time=32.012 ms
64 bytes from seq=1 ttl=116 time=42.346 ms

ping google.com not working
root@GL-AR300M:~# ping www.google.com
ping: bad address ‘www.google.com

I tried different options for the customs DNS, does not work

For the VPN I use OpenVPN

I found a solution by editing resolv.conf and adding manually nameserver
Apparently nameserver pointed to a wrong adress (
Thank you