Can no longer ssh into router "no matching host key type found. Their offer: ssh-rsa"

Security patches are all I want from Windows 10.

I use PuTTY because I like it best, which is the best reason. I like sushi also even if some people not. :grin: :grin: :grin:

I do not work for and I do not have formal association with GL.iNet

Some people like to swim against the current, others with :laughing: :laughing: :laughing:

True! In a democracy, everyone gets to chose!

I do not work for and I do not have formal association with GL.iNet

Hmm :thinking:

Maybe i’m wrong but does that error not say that your public key/fingerprint is wrong?

I can remember (afaik for every client ive used putty or termius).

If you use it for the first time you get asked to accept the public key or fingerprint.

Ive had once a time I clicked cancel and I wasn’t able to login back, got a smilliar error even when I had enabled password authentication, but that doesn’t mean the protocol is inaccessible, in that case you need a way to reset that specific prompt.

Well of course changing client might help, but that doesn’t fix the latter, I once hosted a server then decided to reinstall because of laziness but of course thats not how I would go about how to fix it :yum:

I wonder how does one reset this prompt for putty or OP default client?

Soz, due the off topic comments I kinda got confused about the issue from the OP.

I believe on a linux client there should be a location of /etc/ssh/authorized_keys to reset it?, How does that work on different ssh clients on windows to get a idea?, I think if the OP deletes this file or fingerprint that it may just works again.

This is the solution, explained on on this website.

Please be careful though when executing this command:

$ echo Host > .ssh/config

If you have existing settings in .ssh/config that command will overwrite them. smiths, maybe you could change that line to make an append (>>) instead:

$ echo Host 10..101..16..1 >> .ssh/config

Wow. Not fanning the flames here. But I am struggling a bit with the move from W10 to W11.

On topic: I moved several years ago from putty to xshell. To each their own, I guess.

Off topic: All my Intel hardware is obsolete for W11 solely because of TPM. All my AMD hardware is acceptable. So I really can’t tolerate updating the AMD machines and replacing the Intel machines to use W11. On the other hand, this could be great buying opportunity for used Intel hardware being tossed out.

1 Like

Hi dub4u,

I did think about this at the time, but was too lazy to edit at the time :smile:. My reasoning was by default ~/.ssh/config does not exist. Someone will need to have created and added content, and running cygwin - they were sufficiently “unix” aware to use the solution, and tweak to their needs.

You are correct though, so I have modified my original post.


This is due to dropbear using now deprecated ssh-rsa key.

need openwrt newer than 19.07 to support current ssh algorithms

1 Like

As having the same problem on my GL-AR750S,

worked for me too. But

does not work?! Any idea on that?

The .ssh directory does not exist and has to be created first, then run the echo command:

mkdir ./.ssh

Unfortunately, this doesn’t work either.

Bildschirm­foto 2023-04-15 um 11.15.31

In the screenshot you are setting ssh-rsa at the sshd server side (router), exit the connection.
On the client side (MacBook?) it says server accepts ssh-rsa
Seems to work as expected. Looks like you need to find out what HostKeyAlgorithms is best for your client.

1 Like

Well, the mkdir ./.ssh did work and the echo command was able to create the .ssh/config file. I have no idea about the procedure from smiths :rofl: :rofl:

1 Like

Shouldn’t all these commands execute on your Macbook other than on the router?

worked for me thanks!

1 Like