Can we get an ETA on the next release?

The repositories seem to be broken badly with the 2.25 release…
<pre class=“error”>Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-rtl8192cu:
  • kernel (= 3.18.27-1-e5ed52b8a26964473b4e4d079fbf6f41) * kernel (= 3.18.27-1-e5ed52b8a26964473b4e4d079fbf6f41) * kernel (= 3.18.27-1-e5ed52b8a26964473b4e4d079fbf6f41) * kernel (= 3.18.27-1-e5ed52b8a26964473b4e4d079fbf6f41) *
  • opkg_install_cmd: Cannot install package kmod-rtl8192cu.
  • pkg_run_script: package “kmod” postinst script returned status 255.
  • opkg_configure: kmod.postinst returned 255.
    Anything that touches the Kernel seems to be broken at this time. So, where I can limp-along with what is there with that release…it’s limiting me to find a tetherable hotspot or a supported USB dongle from Verizon. Not useful- I’d hoped I’d side-stepped the issue, but it appears NOT. I was hoping to be able to grab just any old supported device and link it through so that the WISP stuff could be gracefully load-balanced with whatever I came up with to link it however that was. And, “odd, it shouldn’t do that,” isn’t the right answer- somewhere something got munged in the release and it’s not installing ANY of the extra kmod-* packaging right now.

Custom firmware is an option…sort of. No good lists of what you include (which is WHY I asked for it in the first place…sigh…) and now I’m off wandering through the minefield that is OpenWRT/LEDE trying to make it build right.

Please, guys, either get this right so most won’t NEED custom firmwares, or get us a base .config you would use without the GL UI build parts to make a stock OpenWRT/LEDE firmware build for these units.

“Clean” Open/LEDE firmware is aready built and available from the download section.

However, the GL Firmware is fantastic and does almost everything - not really sure what your problem is.

@madscientist_42, which model are you using?

AR300M - Using it right now in the hotel at a customer site. The WiFi as WAN works pretty good, but I would like to be able to be “fancy” and drop a nano-150N so I can load-balance between the current Radio and a MIFI or USB modem dongle instead. My UML290’s non-functional in the slot- but then it’s non-functional unless I plug it into one of my Linux machines or the old craptastic EOL’ed Cradlepoint I have.

Right now, I’m fine with the “enhanced” hotel internet…but I’d like to get more…and it doesn’t seem to work right. When I try to add the kmod’s it tells me that there’s a conflict. Like the whole of what got put up to the repository isn’t in full lock-step with the image that’s the current official one. If I could get that much while I figure out what to do with the Verizon story, I’d be happy- because it WOULD be the swiss-army-knife of road-warrior Internet stuff.

Well, either a new image that I can put stuff onto it…or a good defconfig that covers what you’re building out of the official distribution builder so that I can cobble my own stuff together. I sort-of have something right now, but it’s not quite the same layup as what’s on the official images.

@Glitch Depends on what you’re calling “does everything”. It doesn’t seem to be able to use the software packages in the repo…for starters. And if you’re trying to be “fancy” and do things like dual WAN with WiFi or tricking the thing into using a Telco portable hotspot and a nano-150N dongle as a tether cable…

Well, it doesn’t work as well right at the moment. And it doesn’t seem to want to play nice with my ancient UML290 LTE Modem either. Just because it works nicely for you doesn’t go that it works right for others or that they are trying to use the amazing little boxes in ways you’d not use them… ;-D

Yes, you are right - it does everything I want!

I don’t get “the repositories are broken” - did you do an update? Or you can add your own (Luci>system>software).

If you aren’t happy with the GL firmware, then there is the “clean” build, or you can compile yourself. It’s a project router and I don’t think the things you want to do are even possible with any other device!

I don’t think the repo of v2.25 is broken because we double checked.

But we are compiling repo for v2.26 and hope to finish soon. There are several packages I cannot compile it right and I am fixing it.

Well, I copy-pasted what I was getting when I tried to add the packages in question. I don’t know what’s going on, but there’s something off.

As for what I’m trying…I was wanting to be able to plug in something like an Edimax 150N nano dongle into the USB port and connect it up to a JetPack type device if I couldn’t get a USB dongle for LTE on Verizon- and load-balance between the hotel and my LTE coverage for higher speeds as needed.

Well, that plan got changed. I got the LTE USB dongle, but it best functions as an RNDIS device. Plugged it in on my laptop just now and it just simply connected. No voodoo on the machine needed- it’s all handled in the SIM. No dial strings, no CDC-ACM, etc. There’s an option to put it into CDC-ECM mode, but you need usb-modeswitch and some documentation provided by Novatel and Verizon to do it. Having said this, that still doesn’t work the way one would expect out of a 4G modem- it acts like an ethernet node instead of the typical with AT commands going through a serial emulation.

As such. one still needs to have this sort of thing built in or as an addable module for the build- as well as having one of the more common WiFi’s either built in or downloadable from the package repo.

Good to hear a new version’s about to be out. Even if the problem’s not sorted out, it’s good to know this gem’s decently supported.

As it stands, in spite of my not getting where I’d wanted to get things up to this point, the GL-AR300M’s a marvel and a half- it’s gotten a 5-star review from me over at Amazon where I’d bought mine. If I can get a few of these things sorted out in some manner…I’ll be buying another. One to chuck into a laptop bag for when I need a bit more on location and where I don’t want to tear down my hotel setup to do it.

It’s a swiss-army-knife of networking, making your typical MiFi type device look pathetic in comparison…and I’m telling people that. I just ran into a little snag for some of the things I’d like to do with it that it SHOULD be able to do out of box…and can’t.

Are there devices out there that will do the things you are proposing?

Yes. They’re made by several vendors (Quite a few, actually…)…

And, more specifically to the point…it’s been a type of feature in a feature set for a long time now…

However, it’s not overly relevant for those devices. All of the ones I listed don’t support the Novatel U620L modem which is either RNDIS or CDC-ECM as an actual interface (and has a full-on web interface accessible by…)- something that Windows/OSX/Linux understands and can work with, but most of the older, non-Linux based devices don’t “grok”. I know…I’ve got all but one of the mentioned. There’s a REASON I’m nattering on like I do on this subject here. The GL-AR300M is the closest one to date to support this, and while I can still build the firmware, it’d be “better” if they could provide it as a feature set in the normal UI, amongst other things.

As it stands…it doesn’t work right with the stock firmware. Not even as a single WAN entry for the USB device in question- and with some hacks on much more aggressive (and bulky…sigh…) hardware, it just simply works. I’m trying to keep with stock firmware if I can for obvious reasons- they’re doing an overall good job maintaining it…there’s just some small issues.

Picture, if you will, having two hotel WiFi as WAN connections. You tell it to split the UDP and TCP connection sessions evenly between the two. While it’s not channel bonding, you can see up to twice the throughput when you’re doing BitTorrent, swarm downloads, and similar things. With the right software, you can even channel bond them through a VPN or SD-WAN trunk engine. No help (or agreement) with the ISPs needed. Same trick can be done with two or more 3G/4G modems (With a Hub in this case for the GL Micro-Routers…) or between hotel and 3G/4G modem or tethered Hotspot/Phone. If the Hotel or other WiFi as WAN is fast enough, you can split the total speed (and costs) between the free or nearly so WiFi as WAN and the spendy metered 3G/4G connection.

This has been a “thing” for nearly a decade now on some of the higher end 3G/4G capable routers. And it’s a feature, to be honest, just one click away right now with the stock firmware, if you’ve got a properly supported 3G/4G modem. It’s just messy to use. Even with it being a pain to set up, the functionality being there (and yes, it’s there, click on “advanced” from the GL UI and you’ll see “load balancing” on the Networking options on the OpenWRT menus…) makes this one of the lowest cost devices in the actual class- and one of the most portable and better ones, which goes without saying… :smiley:

I understand what you’re trying to do. I seem to recall a post awhile back from someone who wanted to use a USB wi-fi adapter (for whatever reason) and being told it wouldn’t likely work

Won’t it all be made moot when the two-radio device comes out (assuming the host router supports 802.11ac)? The theoretical speed will be higher than the aggregated speed of two 802.11n devices.

Not really. That would only work if the AP supported dual band operation. In the context of one of the desired used cases, it’s two differing client nodes talking to a CAPWAP or similar managed distributed AP on the 2.4 GHz band on alternating channels, typically 6 and 11. Wouldn’t work with the dual radio- as it’s on two differing bands. And yeah, it would work if you’re using load-balancing…for most things you’d be doing with the added bandwidth- and with some VPN solutions, it WOULD act like you had 10/15/20 Mbits. If I still had my home setup, there’s an OpenSource solution that will do that.

Having said that…at the least the other solutions need to be worked out- because there’s some gaps in GL’s support there. It doesn’t seem to play nice with the RNDIS device I have…but OpenWRT will do it. It should do this because it’d be otherwise something they should support and it doesn’t right now.

The problem in the case I’m describing is that they’re wonder-shaping the bandwidth down to 700kbps max if you’re getting it for free, and down to 5Mbps per MAC if you pay them a fee. It’s $20/30 days per MAC. In the context of an AC link, you’re still talking it being throttled down to those speeds. :smiley:

I’ve got enough devices in my possession that could be leveraging the 5 each that I just want to be able to leverage the full rate for all of them on any one single one of them when I’m not using the other devices. And failing that, I’d like to make my 4G use less so it’s not so spendy and I can manage to afford to stream videos, update Steam or PS4 titles, etc.

There are a few GLi threads on the OpenWRT forum. In one - OpenWrt Forum Archive - the OP is trying to install kmod-sdhci-mt7620 on an MT300A and getting errors. I don’t know if this is related to your problem, but his SD card works anyway. You might check out the log he posted.

Given that the 300A has the daughter card for the SD card I would have expected the software for it to be part of the factory package. He doesn’t identify which firmware he’s using.

There’s also a guy trying to get VPN working and he has absolutely no clue about it, I mean NO clue. I suspect he’s pretty representative of many GLi buyers. I’m only a few paces ahead of him myself.

>>> There’s also a guy trying to get VPN working and he has absolutely no clue about it, I mean NO clue.

When I had the idea to put my VPN on a router, I also had no clue - the guides looked very daunting. But, I decided to give it a go, on both DD and Open WRT. I’m very glad I did and was very happy with the results versus running a VPN client on my desktop.

Then I discovered the GL router (AR300M). It is so simple to get it working on that, even a monkey could do it!

If anyone’s following this thread, v2.26 has been released - GL.iNet download center

2.26 installed. Same problem…
<div class=“cbi-value”>

Installing kmod-rtl8192cu (3.18.27+2016-01-10-1) to root...

<pre class=“error”>Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-rtl8192cu:
  • kernel (= 3.18.27-1-614a690edd3b9a652fa55d68faabbaf9) * kernel (= 3.18.27-1-614a690edd3b9a652fa55d68faabbaf9) * kernel (= 3.18.27-1-614a690edd3b9a652fa55d68faabbaf9) * kernel (= 3.18.27-1-614a690edd3b9a652fa55d68faabbaf9) *
  • opkg_install_cmd: Cannot install package kmod-rtl8192cu.
    There is still something off. About to see if I can at least see/use the 4G dongle…see if there’s an improvement there.


Well, that’s an improvement. Sees the modem as a “tethering” situation. I’ll putter/putz a bit more with the current version with my new 4G hardware. I think it’s “usable” in the context of what’s shipped at this point if it can properly use it as a “tethered” device and still let someone access the Web interface on the unit.

There’s still a packaging problem. Can’t install from the WebUi anything that touches the kernel that’s shipped with the firmware release. Yeah, I know- not supported… Like I said earlier…basic behavior here should be. Other players support load-balance, etc. Shouldn’t be TOO hard.