Cannot access captive portal (Royal Caribbean) - Beryl AX

I am trying to set up the router in the Repeater mode to connect to Royal Caribbean, following the expected steps:

  • Connected to the router WiFi
  • Set the repeater mode and connected to the WiFi-Guest-SHIPNAME (router status page shows it’s connected and displays the IP address).

The next step would be to connect to some site and be dropped into a captive portal but this doesn’t work - it basically times out after some time.

I initially suspected that RC is becoming more aggressive in filtering out certain MAC ranges and tried a different MAC address but it hasn’t changed a thing.

Any clue what am I doing wrong and if there’s a better way to handle this?

1 Like

Can you connect to 'em via a mobile device? Set a ‘random MAC’ on a mobile device (see Wi-Fi Settings; it should be in there somewhere). Connect as you do, go thru the portal, check the weather, whatever. Disconnect.

Take that random MAC from that save Wi-Fi network, toss it into the Beryl AX’s settings. See Solution 2. MAC Clone:

… don’t forget to delete that save Wi-Fi network fr your phone once you’ve got the Beryl AX online. They might have their network set to disassociate all your device MACs if they suspect two of the same on the network. Duplicate MACs are a technical impossibility.™

I had this issue too and figured out a simple fix, at least for my iPhone.

On your phone, forget/delete your Beryl’s wifi SSID after you know it is connected to the RC (ship’s) wifi. Now connect to the Beryl again “for the first time” and it will trigger the captive portal.

Other things to check - Make sure you don’t have any custom DNS settings (DoT/DoH/normal) on your phone or in the Beryl. This can screw up the captive portal redirect.

As others mentioned though, the MAC spoofing worked well for me on my 2022 RC cruise to Alaska.

There are a number of forum posts on problems with getting the captive portal to come up on GL.iNet routers. The first thing is to make sure that DNS Rebinding Attack Protection has been turned off, as described in the URL that bring.fringe18 provided above. Search for “captive portal” in this forum for other posts and possible workarounds, including MAC Cloning,

Personally, I gave up dealing with these router problems when travelling in hotels and on cruise ships and with wasting time instead of having a good time. I just spent 18 days in May this year on Celebrity Cruises, which is part of Royal Caribbean and uses the same captive portal system to access the Internet via Starlink Iow-orbit satellites. When I last upgraded to a new smartphone, I kept my old smartphone and set it up as a multi-user hotspot through either wifi (on ship) or LTE (off ship) that worked with Windows laptop, iPad, Android tablet and smartphones. The old smartphone is small, light and allowed me to move around the ship and on excursion buses running on its battery without worrying about connecting external power.

By the way, be sure to upgrade to the Premium Wi-Fi package, which allowed me to stream Netflix and Amazon Prime Video. The Basic Wi-Fi package is too slow for sharing and for streaming.

I do not work for and I am not directly associated with GL.iNet



Or… (check this out:)


Netflix and Amazon Prime Video cannot be downloaded and played back over SMB.
We all can decide for ourselves how we want to travel. You can do it your way and I can do it my way.

Redundant statement is redundant. That was already implied by my post.

Off-topic. Off-topic. Off-topic. Off-topic. Off-topic. Off-topic.

Great success, problem solved!

The culprit was AdGuard - it was enabled previously and it apparently messes up with DNS requests. Disabling AdGuard (along with using MAC clone) has solved the problem. Thank you everyone for helpful tips!


As if this isn’t:

Geezus; check yourself, Minion. The guy just needed a little introduction to the appropriate page in the manual, not a tirade rooted in technical incompetence. < / shots fired >

@microCFL : Glad you got it sorted. I might suggest printing that page to a pdf & keeping it on your phone/other device in case you find yourself in a similar scenario.

All, this is for others who might have the same problem with captive login from Royal Caribbean not working. I had spent the last 3 days of my cruise trying to figure out why I could never get the login page for the ( site to show up. I followed all the suggestions I could find. I still kept getting the error message that “Google DNS error, can’t find site”.

The solution was simply upgrading the firmware on my MT-3000 Beryl to v. 4.5.0, just published two weeks ago. I had updated as soon as purchasing a few weeks ago, but I guess this latest build fixed the problems with captive networks.

Good luck!

1 Like

Here is the direct link to the firmware download site for this model:

Good luck!

So, soon after finally getting the Beryl MT-3000 working, I had to disconnect from it (which I keep in the cabin) and connect my phone directly to the ship network because I left the room. However, when I returned to the cabin, I could no longer get the captive portal to come up.

Finally I realized that the issue is that I had previously enabled VPN client mode on the MT-3000 to route traffic via my home router. This of course meant that using login. com or no longer worked, and I’d get the “This site can’t be reached.’s DNS address could not be found. Diagnosing the problem” message.

So just disable VPN client mode when first reconnecting to the ship network.

Then use the login. com or onboardicafe. com site to complete the captive login.

Now you can re-enable the VPN if you want.

Also note that I learned that using chrome browser on Android doesn’t correctly show the captive login pages. It’s best to use a basic browser (I was directed by Guest Services to use the default “Internet” app on Samsung Android phone, and it works).

It’s been so frustrating but glad I finally figured this out, though unfortunately nearly at the end of this trip. Good luck.