Cannot access Uboot web UI to debrick router

Hi, I have a AR300M16-ext and attempted to upgrade the firmware but have seemingly bricked the router. I tried to follow the guide here to restore from uboot

But I cannot access the uboot web UI. I have tried

  1. Plugging the router into my computer via ethernet
  2. Holding the reset button while powering on the router
  3. Navigating to http://192.168.1.1

This results in a browser error that the page can’t be reached / loaded. I also do not see the device listed with I run ip addr show.

What do I need to do to be able to access the uboot recovery UI?

Did you install a GL.iNet firmware or a openwrt stock one?

I was trying to install the GL firmware. I believe I attempted to install the 300m firmware instead of the 300m16, which is probably why it bricked :confused:

Is there a way to restore firmware from a USB drive instead of over an ethernet cable?

As far as I know it’s not possible. You must use uboot.

Here are a few idea about the flashing process you should keep in mind:

  • It’s important that the LEDs start to flash when you hold the reset button: holding the reset button, powering the device and waiting for 5 flashes of the LED.
  • I remember about an issue with uboot which leads to fail network connection when not using Windows. Maybe this could be an issue as well.

Oh. And: Your PC must have 192.168.1.2, the router is on 192.168.1.1 - so basically your last step, if it’s not a typo, isn’t correct. :wink:

Also clear your browser cache. Make sure your browser is a fresh session.

It looks by your ip addr show command, you are trying to do this with Linux. This SHOULD work, but there were some issues with Uboot code not working with Linux on some older products. I own both AR300M and AR300M16 routers, and have been able to use Uboot with Windows 10 to load both GL iNet and OpenWrt firmware.

On Windows 10, I set the PC IP address to 192.168.1.2, and make sure the Ethernet connection is made before power on the router.

I’m not sure if it is the same but for my Flint router I actually do 1 and 2 reversed.

Basicly I do the following:

  1. have ac coord unplugged from the router
  2. add one ethernet cable in lan1
  3. hold down the pin
  4. when i hold it down i connect the ac coord.
  5. then wait the 6s (long led indicator if present)

Then do the static ip configuration like also other ppl said :+1:, if i don’t do it in these steps it will not give me uboot the step of when connecting the power and when reset is being hold is very crucial :slight_smile:

I don’t think you are doing is reversed.

Have to insert the Ethernet cable before powering on. Both of you are doing it correctly.

1 Like